Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

The iTunes on my secondary computers (i.e. the computers I don't sync my iPod and iPhone to) are now prompting me twice to 'log-in to my iTunes account to enable automatic downloads' before I can play any music - first when I open iTunes and again when I go to actually play a song. While I have music in iTunes on my non-primary computers, I don't need or want them to be connected to my overall iTunes account - I buy almost nothing through iTunes and just don't want or need them to be connected.

This is the box that pops up twice (that has somehow autofilled my email address even though I've never used the account on this machine's iTunes):

enter image description here

I checked system preferences and didn't see anything that would appear to disable the pop up, but anyone know how to get rid of it?

I realize this is a fairly basic question but it's super annoying. Both computers this is happening on are macs, if it matters.

EDIT: This is what the Store Preferences page looks like - I don't see an option for disabling downloads, only ways to enable it via an iOS device or to a different account.

enter image description here

share|improve this question
add comment

1 Answer

up vote 2 down vote accepted

Essentially, there are two different options you can try - depending on the way you want to use iTunes. I'll be writing this answer for Mac users, but Windows users can probably suss it out using these instructions.

Both options will only require you to click "Store" from the menu bar from within iTunes.

store menu

Option One (red) - If you intend on using the Store, you can simply click the "Authorize This Computer..." menu option. This will prompt you for your password and tie your computer and iTunes library to your iTunes account.

Option Two (blue) - If you don't intend on using the Store and would simply like to not see the dialog box prompting for your password, you can click the "Sign Out" menu option.

One of these two things should solve the problem of the persistent password prompt.

Best of luck!

share|improve this answer
    
I did option 2, totally worked. Thanks, great answer. –  Katey HW Jul 26 '12 at 18:37
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.