Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

For 3 days, I now got a new rMBP. I am a first time Mac user.

I had a friend with a MBP and it usually wakes up in a mere second, as soon as he opens the laptop's lid up. However in my Retina MBP, it takes a few seconds (3-5s) to wake up.

Is this normal?

share|improve this question

5 Answers 5

up vote 15 down vote accepted

After the rMBP or the MacBook Air are left sleeping for one hour, they enter a deep sleep mode in order to conserve battery. Traditional Macs without SSDs do not enter this mode, so they might awake from sleep a bit faster.

To answer your question, that is normal behavior.

share|improve this answer
    
Oh never knew that, interesting fact. Can you please provide a source to your info ? Regards –  Render Jul 23 '12 at 16:47
1  
Well, Apple doesn't give lots of details about how these features work, but Engadget gave some basics in its review of the 2010 Air: engadget.com/2010/10/26/macbook-air-review-late-2010. If you're familiar with how PCs have hibernation, it's the same concept. You'll find the file where they write the RAM to disk on your drive at /private/var/vm/sleepimage –  Nathan Jul 23 '12 at 17:17
2  
Apple has a KB article about it: Apple Portables: About standby mode –  Lri Jul 24 '12 at 18:24
    
Another note is that if your friend's MBP was plugged in, it oftentimes doesn't go to sleep (as I've experienced), giving the impression of a really fast wakeup time. –  daviesgeek Jul 25 '12 at 4:03

To confirm that you're in Deep Sleep mode, open Terminal and type

pmset -g | grep hibernatemode

The output should be hibernatemode 3, with the 3 indicating that you're in Deep Sleep mode. This is useful if you're putting your computer to sleep and you're low on battery—if your battery dies in sleep, your session isn't lost. But you get that 3–5 second delay, which can be annoying when everything else is blazing fast.

If you're like me and have the battery charged most of the time (keep it plugged in 90% of the time—it's the charge cycles that kills your battery, much more than any debatable effects of overcharging. Use the battery 10% of the time to keep the electrons flowing), you can disable Deep Sleep and get rid of the delay.

Type sudo pmset -a hibernatemode 0 in Terminal. It'll prompt you for an admin password. Type it in (note that it won't show up when you're typing, but it is being entered) and hit Return, and you'll have no delay when waking up. You'll also recover as much disk space as you have RAM, and those 8GBs or 16GBs are significant, especially if you're on a 256GB SSD.

Note that I've had occasional issues when waking with the recent SMC update (black screen and nothing happens until reboot), but even with a reboot you don't loose your session.

Source: http://www.macworld.com/article/1053471/sleepmode.html

share|improve this answer
1  
OS X ignores the hibernatemode setting since the 10.8.2 update, at least on my retina Macbook Pro. The solution is to set the standby delay to a sufficiently high value, like 24 hours: sudo pmset -a standbydelay 86400. –  n13 Dec 2 '12 at 0:46
    
I've actually just went and set the hibernatemode after the update and I still wake instantly. –  FeifanZ Dec 2 '12 at 3:51

Here is a post about how to fix the slow wake up time. Its about sleep mode goes into standby mode:

Apple now uses a new powersaving mode to fulfill the 30 days of standby. The new MacBook Pro’s and Air’s are now switching after a delay of 1 hour from sleep modus to standby. In the standby mode the content of the RAM will be written to the hard drive and the RAM is powered down to further extend battery life. When you wake up the MacBook from standby, the content must first read back to the RAM and this can take some seconds depending on the RAM size.

With a simple terminal command you can change the delay time before the MacBook will switch to standby. The command uses seconds for the time value. So e.g. if you want to change the delay time from 1 hour to 12 hours you need the value “43200” for the command. It depends on how you use your MacBook to which value you set the delay.

Change MacBook Wake Up time with terminal command:

  • Start Terminal in Application -> Utilities -> Terminal.app or type Terminal in the spotlight Search.

  • Type sudo pmset –a standbydelay 43200

You can also disable the standby mode completely with 0. Mostly I don’t shutdown my MacBook and set my delay to 24 hours (86400)

To view the current settings use pmset -g.

share|improve this answer
1  
Links may break over time. Could you please summarize the content of your source? –  gentmatt Sep 26 '12 at 8:31
1  
This is the fix. I just want to add that disabling hibernatemode doesn't work anymore - you also need to disable standby or set the delay sufficiently long. I do "sudo pmset -a standbydelay 86400", 24 hours is fine. –  n13 Dec 2 '12 at 0:49

This post is a little older, but I found it very helpful. Instead of using terminal, though, you could just enable Power Nap by going to System Preferences, Energy Saver, Battery, then click the box to Enable Power Nap While on Battery Power.

I got this info from http://support.apple.com/kb/HT4392. Here's the pertinent content below:

The standby mode activates after just over an hour of "regular" sleep. To enter standby, the computer must:

  • Be running on battery power.
  • Have no USB devices attached.
  • Have no SD card inserted.
  • Have no Bluetooth devices currently paired.
  • Have no external display attached.
  • Have Power Nap disabled (if it is supported on your Mac).
share|improve this answer

In addition to what Nathan said, if you have any external drives connected up as well, the system remounts them before presenting you with the login screen also. So if you have a slow hard drive/optical drive connected, it may take a bit more time to fire back up again.

share|improve this answer
1  
Thanks for the info :) –  Render Jul 23 '12 at 23:23

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.