Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

There's this network at my school which I know requires a username and password. If I access it on my PC, it asks for it, and I give it, and I get access. Works great.

On my Mac, when I select it from the drop down list of detected wireless networks, it asks me for just a password. Like this is some normal home network. Which is wrong. Inapplicable. No.

How can I get it let me put in my username and password instead?

share|improve this question
add comment

1 Answer

up vote 2 down vote accepted

This should work, but, as this is working with tech, you never know:

  1. Open System Preferences.
  2. Select Network.
  3. Select "Wi-Fi" on the sidebar (AirPort if you're running SL or earlier).
  4. Click "Advanced..." in the lower right.
  5. On the Wi-Fi tab, click the plus sign beneath "Preferred Networks".
  6. Enter the name of the network that you want to connect to.
  7. In the security drop-down, select "Any (Enterprise)".
  8. Log in with your username and password.
  9. Press OK.
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.