Ask Different is a question and answer site for power users of Apple hardware and software. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I recently bought a MacBook Pro Retina. The first day I was able to connect my Huawei E352 3G USB modem and it worked all the day. After a couple of day I needed 3G connection again, but my MacBook Pro Retina does not recognize the modem anymore. There is a micro SD card in it, and it also does not mount. The modem works with my iMac flawlessly. All the MacBook Pro Retina USB ports work flawlessly, and recognize any other devices (pen drive, Blu-Ray writer, USB 3 external hard drive).

Any ideas as to why the modem doesn't work anymore?

share|improve this question
When you took it out the last time you used it, did you eject it first (right click and select Eject)? – Matt Jul 18 '12 at 13:05
Actually I am not sure whether I did so. I think rather not. – Zoltán Jul 18 '12 at 13:30
Does it work after rebooting the mac completely? – Thorbjørn Ravn Andersen Apr 16 '13 at 11:08
If you are using the modem just at home, you could create a wifi network from your iMac to the MacBook and just run it like that. – bret7600 May 10 '15 at 13:52

The issue is probably that by pulling out the modem without safely ejecting it first, the MicroSD card became corrupted and/or the modem itself was damaged.

The simplest and quickest fix may be, unfortunately, to get a new modem.

share|improve this answer
Thanks Matt, but if it is corrupted, why does it work on any other device? I tried with my iMac and a PC and both the modem and the micro SD works. – Zoltán Jul 18 '12 at 13:51
That's something different... (and probably something you should've included in your question). Have you rebooted the computer in question? – Matt Jul 18 '12 at 14:01
Yes, I have. (Sorry, in my original question I mentioned that it works with my iMac.) – Zoltán Jul 18 '12 at 16:01

The Huawei modems are terrible. But regarding your problem, I've had it too, and the good news is that there is an easy fix. Provided it's visible in Disk Utility, open Disk Utility and select your device and run Verify and Repair Disk permissions. Run both the root and the sub disk.

share|improve this answer
You want to run Disk Utility on an USB Modem? – patrix Mar 16 '13 at 10:36
Yes? the huawei usb modems all have a micro sd card, it works by repairing disk permissions! – Macmaniman Mar 16 '13 at 20:59

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.