Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I've tried deleting and reinstalling AirPort Utility, but I can still manage base stations without being asked for a configuration password.

I'm thinking of selecting not to back up data from AirPort Utility, then making a backup to iCloud and wiping and restoring the device. Has anyone tried this?

share|improve this question
    
My guess is that the password is stored in a system keychain and not in the application bundle. Have you simply tried a soft reset of the base station to restore the default password? That should allow you to use another trusted device or computer to make a new password. –  bmike Jul 18 '12 at 16:06

4 Answers 4

Since iOS doesn't have a keychain utility to go in and surgically remove the stored password, you would have to either:

  • change the password on the base station to effectively lock out all clients with the old password.
  • erase the iOS device and refrain from restoring a backup that contained saved passwords onto the device. (Encrypted backups of the device typically store keychain items, non-encrypted backups don't save those passwords, so you might try an unencrypted backup, restore the backup and then test if the password was saved in the application bundle as opposed to a keychain).
  • As a long shot, try enabling iCloud keychain syncing and see if you can clean things on a Mac that has iCloud keychain syncing enabled as well by opening the iCloud keychain in Keychain Utility.
share|improve this answer

Haven't tried your approach, but apparently you can't delete the passwords. After doing a little research I've found a lot of people complaining about this same issue, even in the App's Review.

Although a nuisance, changing the password should revoke the management privileges of device, if that's what you're looking for.

share|improve this answer

Did you try changing the passwords on the Airport devices? Airport Utility for iOS should show a new prompt to enter the passwords. Enter the new ones and change your Airports back to the old password.

share|improve this answer
  1. Change the password on the base station.
  2. Update the base station
  3. Do not store new password
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.