Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I know there's probably a setting in preferences, but I need to be able to do it without Word being open.

The problem is one of my docx has become corrupt, so every time Word opens it immediately stops responding and I can't access preferences.

Is there a way to clear a cache or something somewhere so Word forgets about these files at startup?

share|improve this question

3 Answers 3

up vote 7 down vote accepted

From the macrumors forums you can hold shift when you launch a program to launch it without the resume previous window functionality.

Alternatively, for those who want some resume functionality and don't want to globally disable it, you can hold Shift when you launch an application to bypass resume and start that app fresh.

If that doesnt work you can turn off the function globally by going to System Preferences -> General and unticking "Restore windows when quitting and reopening apps"

(you can also disable the function on a per-app basis using the instructions here)

share|improve this answer
    
+1 thank you! and genius! –  andy Jul 18 '12 at 3:28

I tried orangebox's and Adam's instructions and linked instructions but it didn't do the trick, so I tried the following:

  1. Opening up, in this case, Excel, close all documents and quit Excel.
  2. Open up the following folder: ~/Library/Saved Application State (you can also use the Cmd+Shift+G shortcut in Finder)
  3. There you can search for the application folder. For me the folder is com.microsoft.Excel.savedState.
  4. Select it, use Cmd+I for an information window on this folder and check the "Locked" option.

Now Excel can't change the savedState folder and will always open with a blank spreadsheet, which is at least faster for me.

When you drag a document on Excel (in the Dock for example) it will open it normally. Closing Excel and reopening still gets me a clean spreadsheet.

share|improve this answer

You want to disable the resume functionality in Microsoft Word 2011, which will prevent it from trying to reopen documents when the program is launched. Enter the following command in the Terminal:

defaults write com.microsoft.Word NSQuitAlwaysKeepsWindows -bool false

There are also full instructions on how to turn off resume for an arbitrary program.

You can also turn-off resume at the operating system level in System Preferences > General then uncheck "Restore windows when quitting and reopening apps".

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.