Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I just opened my new Retina Display MacBook Pro and everything worked fine, but when I tried to go into System Preferences to make the key repeat speed faster, none of the keys repeated, not even numbers and symbols.

If I type defaults write -g ApplePressAndHoldEnabled -bool false into terminal, it works, but it disables the accented key popup when holding down keys such as A and E, which I use often.

This worked perfectly on my old 2009 MacBook Pro that was running 10.7.4. I have restarted this computer and reset the key repeat speed, but have still had no luck. Any help would be greatly appreciated.

share|improve this question
    
I have the same issue and I tried changing both repeat speed and delay until repeat speed. –  Michael Durrant Jul 31 '12 at 21:12

1 Answer 1

It probably wouldn't help, but you could try changing the keys directly in ~/Library/Preferences/.GlobalPreferences.plist or ~/Library/Preferences/ByHost/.GlobalPreferences.*.plist.

defaults write -g KeyRepeat -int 2
defaults write -g InitialKeyRepeat -int 15
defaults -currentHost write -g KeyRepeat -int 2
defaults -currentHost write -g InitialKeyRepeat -int 15

2 and 15 are the fastest settings shown in System Preferences. The changes aren't applied until you log out and back in.

The file in the ByHost folder doesn't normally have keys for the settings, but it has precedence over the normal .GlobalPreferences.plist.

You can remove the keys with the delete subcommand:

defaults delete -g KeyRepeat
defaults delete -g InitialKeyRepeat
defaults -currentHost delete -g KeyRepeat
defaults -currentHost delete -g InitialKeyRepeat
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.