Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

My machine name is set shiny in System Preferences/Sharing/Computer Name.

From another machine on the network, I can only use shiny.local to refer to this machine. In the past, I used only shiny.

In a terminal, I have new-host-7 instead of the machine name.

I don't know if this is relevant, but the computers are connected to an internet box, on which a DHCP server is activated. I assigned a static IP address to the Mac. The internet box can see the name I gave to the Mac.

Is there something I can do to refer to the Mac as shiny on the network ?

share|improve this question
    
Sounds like the DHCP server assigns the name... –  Max Ried Jul 10 '12 at 17:06
add comment

2 Answers 2

Try using sudo scutil --set HostName shiny and sudo scutil --set LocalHostName shiny then close your shell (Terminal window) and open a new one.

share|improve this answer
    
It's working locally. I'm using two interfaces on the Mac, but one of them if down(Wifi) at home. Other machines keep on thinking shiny's Wifi address is still valid though. –  Antoine Lecaille Jul 10 '12 at 16:31
    
That sounds more like a DNS issue; are you running any kind of local DNS service, even if only in your router? If you open your Sharing prefpane and click Edit under Computer Name, do you have dynamic global hostname enabled? –  da4 Jul 11 '12 at 15:09
    
No, it's not enabled. Should it ? There is only a DNS service in the router. –  Antoine Lecaille Jul 12 '12 at 9:45
add comment

I figured it out here - (the scutil command is nice to know but didn't work)

Access your router (usually 192.168.1.1 or something) and look for the list of devices. On my Verizon Router this is under "My Network." You should be able to rename them there.

The problem I found was that my computer had two different IP connections to the router: one was the ethernet, the other was the wireless connection. The wireless connection had the correct name, the other one had "new-host-5". You can't have the same name for both, so rename the wireless connection to whatever, and then change the name of the ethernet connection to what you want. (Also I just disabled the Wireless connection, because I don't need both... Don't know if that was necessary though) Hope This helps!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.