Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I have a few email accounts set up in Mail. One of them is my xxxxx@mac.com email address. At some point (maybe after I switched to iCloud), Mail started including the xxxxx@me.com address in the list of potential from: addresses. Is there any way to convince it to not include the @me.com address? I don't ever want to use it.

Edit

Sorry, I may have been unclear. I want to continue using the xxxxx@mac.com address. I just don't want the xxxxx@me.com address in the popup list or to have Mail automatically enter it in the From field when I create a new message.

share|improve this question
    
If it were me, I'd simply remove the account. Is that not an option for you? –  ephsmith Jul 10 '12 at 4:12

4 Answers 4

up vote 1 down vote accepted

Actually, if you just want to remove the "@me" from the "from" drop down when creating an email (I found this excruciatingly annoying), go to Preferences, Account Information, and then in the Email Address field, delete the "@me" address, so that only your cool .Mac is in there.

share|improve this answer
    
GET OUT!! What f**ed-up mental block did I have that kept me from trying that? I'm so happy to give you your first accepted answer. –  SSteve Sep 6 '12 at 22:13

Go to Mail's Preferences / Accounts / Advanced and deselect the Activate this account checkbox. This should do the trick.

share|improve this answer

If you want to completely remove the account and all associated data from your hard drive.

Go to: Mail > Preferences

enter image description here

In the tab choose Accounts:

enter image description here

Chose your .me account:

enter image description here

Here you can remove it with the - button

Then in the popup simply choose to remove:

enter image description here

share|improve this answer

This is a long shot, but maybe try this:

  • In your iCloud account preferences in Mail, click on the ""Outgoing Mail Server (SMTP)" menu
  • Choose "Edit SMTP Server List"
  • Add a server for smtp.mac.com
  • Use default ports
  • Set Authentication to "password" and enter your @mac.com username and password
  • Choose the server you just set up as the server for your mac.com account

That setup works for me to send from mac.com instead of me.com, but I'm not sure if that's because it was somehow grandfathered in or not. Curious to know if it works for you.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.