Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

When I'm stumbling around trying to find the keystroke for lowering the screen brightness in quarter-segments (which happens to be Option ⌥+Shift ⇧+Brightness-down (F1)), I usually wind up hitting Command ⌘+Brightness-down, which puts my multi-monitor setup into mirrored mode, thus messing up my window arrangement and sizing.

I'd like to turn off this keystroke (which is, specifically, +Brightness-down and definitely not +F1. If someone can come up with a way to permanently disable display mirroring under all circumstances, I'll probably put together a bounty for you.

I'm running OS X Lion on a sufficiently recent MacBook Pro.

I'm not sure why they include mirrored mode in modern computers, anyway. It's never useful and it only confuses people. Don't tell me it's for presentations: any decent presentation software will have a presenter mode that everyone should learn to use and love.

share|improve this question
    
I recommend you try Stay (google "stay for mac"). It's a great tool for setting default placements for windows, and being able to set all windows to their default across multiple monitors with one click. Might help with the window arrangement problem –  XAleXOwnZX Jul 9 '12 at 22:51
    
@XAleXOwnZX I could, but the window arrangement isn't the problem. The problem is the fact that I can accidentally turn on mirrored mode with a single keystroke. –  CajunLuke Jul 9 '12 at 22:55
    
@XAleXOwnZX And, actually, it's just proof that almost every one of my apps is written incorrectly (Chrome, Eclipse, Java, Firefox, VMware Fusion, Outlook, a few others) because they all stay resized in the wrong part of the screen but the Terminal realizes what went on and moves back to where it's supposed to be. –  CajunLuke Jul 9 '12 at 22:57
    
I guess enabling "Use all F1, F2, etc. keys as standard keys" in Keyboard preferences would be even worse, right? –  Thecafremo Jul 10 '12 at 8:09
    
In re the mouse-over gripe: I use a dual-display Mac all day, but when I have a student or a faculty member sit next to me so I can demonstrate something on the screen, switching to mirrored mode so they don't have to lean over my lap is priceless. Why the function needs to be triggered by a key combo, though, is mysterious. –  IconDaemon Jul 10 '12 at 13:21
show 5 more comments

1 Answer 1

up vote 2 down vote accepted

There doesn't seem to be an entry for the shortcut in com.apple.symbolichotkeys.plist. The media keys cannot be configured in DefaultKeyBinding.dict or keylayout files. I didn't find any hidden preferences with strings either.

I was able to disable it with KeyRemap4MacBook, but only on my laptop's keyboard; not on an Apple Wireless Keyboard.

  1. Save a file like this as ~/Library/Application Support/KeyRemap4MacBook/private.xml

    <?xml version="1.0"?>
    <root>
      <item>
        <name>Disable Command-F1</name>
        <identifier>private.disable.command.f1</identifier>
        <autogen>--ConsumerToConsumer-- ConsumerKeyCode::BRIGHTNESS_DOWN, ModifierFlag::COMMAND_L, ConsumerKeyCode::BRIGHTNESS_DOWN</autogen>
        <autogen>--ConsumerToConsumer-- ConsumerKeyCode::BRIGHTNESS_DOWN, ModifierFlag::COMMAND_R, ConsumerKeyCode::BRIGHTNESS_DOWN</autogen>
      </item>
    </root>
    
  2. Press the ReloadXML button and enable the new remapping in the first tab

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.