Ask Different is a question and answer site for power users of Apple hardware and software. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have an iPhone 4 which I tried to install Cydia on, and everything worked well. However, when I tried to put it in DFU mode, it shuts down. I attempt to power it back up but nothing happens. What could be causing this problem?

share|improve this question

Try plugging in to computer then press the home and power button, it usually worked for me.

share|improve this answer
I agree, on this newest Evasi0n jailbreak I noticed that recovery mode works best if its already plugged in to the computer. Home and power button, release power when apple logo comes up and hold home button for another 8-10 seconds. It should connect then! – PaulWalnuts Feb 14 '13 at 13:30

It hasn't shut down - DFU mode displays a black screen, so you might think it has shut down. Go ahead and do whatever thing you wanted to do in DFU mode.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.