Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

My neighbors just setup a Wi-Fi network, and my MacBook is now automatically connecting to it.

  • I've never manually connected to it
  • It has a single bar ("dot") of signal, my network has all 4

This is starting to get on my nerves, as I run lost of server software on my computer that I need access to from my other devices, and I don't want my neighbors to have access to. Additionally, I run a BitTorrent client often, and I feel bad using it on someone else's network, due to the high bandwidth usage.

Note that I do have a terrible router that's normally sold for $10 now, and I do lose wireless for ≈ 10 seconds every hour or so, and it might see the other network as a good alternative to no network. How can I prevent it from connecting automatically, other than asking the owner to set a password? Also note that my admin is quite paranoid, and I have very limited access to the Network. My options are "Turn AirPort Off", "Network Name", and "Show in menu bar". "Ask to join new networks" is permanently checked, and I have no advanced options. Might there be a "forget network" feature like on iOS?

share|improve this question
    
If your admin is paranoid and does not give you the options needed - ask him what to do –  Mark Jul 7 '12 at 23:26

4 Answers 4

up vote 4 down vote accepted

If you go to Network Preferences in System Preferences, you should see a button labeled "Advanced" click on that to get to a window with many different network options. Click on Wi-Fi at the top and then rearrange/delete/add networks as you see fit. Then hit ok and you should be good to go! Depending on your OS this may not work, I have no idea. I am on Lion.

share|improve this answer
    
Deserves a +1, but "Also note that my admin is quite paranoid, and ...... I have no advanced options." –  tkbx Jul 7 '12 at 15:15
    
Can you click "Join other network" on any of the Network related windows? –  Zizma Jul 7 '12 at 15:55
    
if you mean manual SSID and security entry, then yes. –  tkbx Jul 7 '12 at 18:50
2  
Hmm, at this point I don't know. Sorry. Haha, you could try having them password protect it or, like above, you could ask your admin. :P Sorry, wish I could help. –  Zizma Jul 8 '12 at 4:02
    
@Zizma Apparently wifi connections problems with some macbook pros is a known issue to Apple. –  Simon May 30 '13 at 16:27

I discovered an issue with my home network similar to this. After scratching my head for hours (contrary to popular belief, I have proven this does work!) I discovered one of my four access points was set to WPA2 when all the others were set to WPA security. My devices prefer WPA2 to WPA, and so even when the signal would nominally dictate my devices should be switching AP, they were clinging on for dear life to the weaker signal WPA2 AP. now I have set them all the same and AP roaming works like it should.

If your neighbour's AP is set to 'better' security maybe this is worth looking into. I.e. you have mixed security on your network, your Macs get confused and connect to the unsecured network.... I know, it's a stretch but worth looking at.

share|improve this answer

Best option is what Zizma pointed out, so better get in touch with your admin and ask him to rearrange/delete the network.

share|improve this answer

Just to add to Zizma's answer:

If your preferred network is already shown & you still can't connect to it automatically, delete it, by highlighting its name & clicking the minus button & then reselect it from the WiFi icon located in the menu bar.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.