Ask Different is a question and answer site for power users of Apple hardware and software. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a new 2012 Macbook Air (with 10.7.4) which doesn't connect to my own local network automatically after it wakes up. I have to choose my network manually and it works instantly.

Any ideas how to solve this problem?

share|improve this question
up vote 1 down vote accepted

I had similar issues with earlier versions of 10.7 as well as 10.6. I can't guarantee that my problem is a match to yours, but I'll share what worked.

In both cases my network had somehow been lowered in priority in the list of "Known Networks" and the list had become a bit bloated in one instance. Ever since, I've made it a point to somewhat regularly visit and clean up my list of known networks.

Note: What follows may not resolve your problem, but it's a good step to take. If it doesn't, I suspect that it's related to a more touchy Wifi issue for Macs running Lion. I recall that there have been at least 2 updates to 10.7 that addressed issues with reconnecting to Wifi when waking from sleep. I've seen it, but it's rare for the Macs that I manage.

Here are the steps that worked for me:

  1. Visit System Preferences -> Network, select "Wifi" and click the lock (if needed) to authenticate.
  2. Assure that "Remember networks this computer has joined" is checked
  3. Note the order of the "preferred networks" (see blue box in the figure). Re-order these appropriately. If you'd like to start fresh, just clear the list.
  4. Click "Ok" to accept the changes

enter image description here

share|improve this answer
deleting and readding solved it. – Pfitz Jul 6 '12 at 13:36

In the event ephsmith's doesn't work I found an additional issue with my own setup.

My macbook wouldn't connect after my AP decided to reset it's settings. During the configuration, I'd set the SSID before enabling WPA. This caused the macbook to remember the unsecured AP only and wouldn't automatically join the WPA protected instance. By removing the unsecured access point from the list from "Preferred Networks" (and ensuring "Remember networks this computer has joined" (as mentioned above) fixed the problem.

share|improve this answer
Thanks. That was the exact problem, I had saved the SSID before enabling WPA. By removing the access point from the list, rebooting and rejoining, it works fine now – user51377 Jun 17 '13 at 0:18

Uncheck "Ask to join network". This will resolve your issue.

share|improve this answer
If I understand the question correctly, the asker had to check the option specifically because it didn't work unchecked. – patrix Jan 12 '13 at 10:18

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.