Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I just purchased an iPhone 4S and I am using iOS 5.1.1. Only one of my Google calendars is syncing. I've searched the web and have tried every suggestion, nothing is solving the problem.

share|improve this question
    
You need to be more specific. Please edit your question and update it with more information so that we can help you even better. What have you tried so far and how? What happend when you tried the other suggestions? –  gentmatt Jul 3 '12 at 19:36
    
I've tried so many thing I'm a little lost.. but here's the best list I can remember of what I've tried: changed sync from iclould to my computer (which is a PC)... and when that didn't work I went back to backing up with icloud; removed my calendar account completely and re-installed it.. twice, once with Exchange and once with Google; via Safari on my phone went to m.google.com, signed in, selected my phone and selected the calendars that I wanted to show up on the phone; all that is just in the last hour...other before that were checking logical basic settings (time zone) rebooted too –  Pam Jul 3 '12 at 20:07
2  
I finally found the solution this evening ... here's the link: support.google.com/calendar/bin/… –  Pam Jul 5 '12 at 0:38

3 Answers 3

Maybe you have only enabled CalDAV syncing for the one calendar that works?

On this page you can select which calendars are to be synchronized to the CalDAV devices*: https://www.google.com/calendar/syncselect

*) iPhone etc.

share|improve this answer

You'll need to make sure that your account is properly configured in Settings > Mail, Contacts, and Calendars.

Since you're using Gmail, make sure that Calendars are set to ON and then go to the Calendar app and make sure all the calendars are selected to be displayed by tapping "Calendars" in the top left corner and checking off all the calendars you want to see from your Gmail account.

Screenshot, turn Calendars ON after adding your Gmail account to Mail, Contacts, Calendars

share|improve this answer

We're looking for long answers that provide some explanation and context. Don't just give a one-line answer; explain why your answer is right, ideally with citations. Answers that don't include explanations may be removed.

    
I've tried so many thing I'm a little lost.. but here's the best list I can remember of what I've tried: 1) changed sync from iclould to my computer (which is a PC)... and when that didn't work I went back to backing up with icloud; removed my calendar account completely and re-installed it.. twice, once with Exchange and once with Google; via Safari on my phone went to m.google.com, signed in, selected my phone and selected the calendars that I wanted to show up on the phone; all that is just in the last hour....other before that were checking logical basic settings (time zone) –  Pam Jul 3 '12 at 19:56
    
I don't see the option to turn Calendars ON in settings.. I see the option to turn on new invitation alerts –  Pam Jul 3 '12 at 20:18
    
and I have checked all the calendars I want to see from the calendar program –  Pam Jul 3 '12 at 20:19
    
1) go to Settings > Mail, Contacts, and Calendars. 2) select Add Account... and add your Gmail account. –  JaKXz Jul 4 '12 at 13:42
    
I have found the solution. Here's the link...support.google.com/calendar/bin/… –  Pam Jul 5 '12 at 0:36

That's the google recommended way http://support.google.com/mobile/bin/answer.py?hl=en&answer=139206

share|improve this answer
    
Hi Elibyy - I actually did exactly what the link stated but it's still not working. It must be a bug in the 5.1.1 operating system. I've looked at an Apple iPhone blog today as well and there are a lot of posts about this problem, so I'm not the only one. Thanks for trying to help me. –  Pam Jul 3 '12 at 23:19
    
It worked for me on iOS 5.1.1 you need to go to the cal app. And wait a few. Also there's a button on top left. Check there for the cal –  elibyy Jul 4 '12 at 3:49

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.