Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

When I wake my Mac mini from sleep, it occasionally comes up with a dialog saying "The name of your computer "whatever" is already in use on this network. The name has been changed to "whatever (1)"" (or (2), I'm up to (4) at the moment).

The Mac is plugged in to the network via an ethernet cable and gets a DHCP assigned IP address from my router which runs pfSense. I have DHCP set to give the same IP address to the Mac's Mac.

Why does this happen, and more usefully, how can I make the machine stop renaming itself?

In System Preferences - Sharing I have 'File sharing' and 'Remote Login' enabled.

share|improve this question
add comment

3 Answers

up vote 2 down vote accepted

Usually this is the fault of the router and the Mac is responding to conditions out of its control.

Have you tried using a fixed IP address or making a DHCP reservation so that your Mac more reliably claims the same address when it wakes from sleep?

share|improve this answer
    
No when I have this the IP stays the same but the name changes –  Mark Jan 11 at 22:26
    
@Mark - The IP address is allocated based upon the MAC address of the sender of the DHCP request. It's still possible the router could be to blame - but it doesn't have to be as you commented. –  bmike Jan 11 at 23:34
    
true - bit this answer says make the Mac claim the same IP address and that definitely is not the issue I see –  Mark Jan 12 at 0:44
add comment

I've seen this happen when the local DNS server has DNS caching enabled, but doesn't flush the cache often enough (or at all).

You can set your Host Name/Computer Name to a static value using scutil in Terminal. This means that your Mac will no longer change it's name automatically, so it's important that there are no other machines on your network that actually have that hostname. When you run this, replace "new_hostname" with your desired hostname:

sudo scutil –-set HostName new_hostname

sudo scutil –-set LocalHostName new_hostname

sudo scutil –-set ComputerName new_hostname

You can check to make sure the values are set by running:

sudo scutil –-get HostName new_hostname

sudo scutil –-get LocalHostName new_hostname

sudo scutil –-get ComputerName new_hostname

Sources: https://developer.apple.com/library/mac/documentation/Darwin/Reference/Manpages/man8/scutil.8.html

http://osxdaily.com/2010/09/06/change-your-mac-hostname-via-terminal/

share|improve this answer
add comment

This happens to me on occasion most typically when the OS has some sort of hiccup and needs a cold restart.

  1. Unplug the router. For some reason after the restart, the computer has trouble connecting with the network as the, router "thinks" that a connection was never broken in the first place. Given a connection can't me made with the given username, the operation system adds a (1, 2, 3…) to the end of the name.

  2. Restart the computer.

  3. Go to preferences/Sharing and change the name of your computer from "Your Name's iMac (2)", to "Your Name's iMac"

  4. Plug the router back in.

  5. Connect to the network.

Worked for me!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.