Ask Different is a question and answer site for power users of Apple hardware and software. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I unplugged my iPhone without clicking the eject button. Now the computer doesn't recognize it in iTunes.

I have followed everything in the help section but still no luck.

share|improve this question
What "help steps" did you follow? We will need a bit more information to properly assist. – ephsmith Jul 3 '12 at 0:59
Did you reboot your PC? Did you reboot your iPhone? – Martin Jul 3 '12 at 14:24

The built in help (on Mac at least) doesn't have the good troubleshooting articles that does.

I would start with running a Device Sync Test in iTunes and if that won't even run, you can fall back to the Device Connectivity Test.

That should pinpoint the source of the issue if it's not software to:

  • OS issue
  • USB hardware failure (on the computer, cable or device itself)
  • Hardware failure of the device (get it repaired / restored by taking it to another computer)
share|improve this answer

I haven't had this problem with an iphone but I have with an ipod. To resolve I opened it on another machine. The other pc didn't think itunes was still open for it and so opened it up. When I went back to the original machine it worked fine again.

share|improve this answer

Try restarting the iTunes Helper process in Task Manager. Otherwise reboot your device and your computer and that should take care of it.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.