Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I like to adjust my terminal window size to fit whatever I'm working on at the moment—sometimes a tiny screen just to tail a log file, and sometimes I stretch it all the way across the screen to read some wide output.

Whenever I open a new tab in the Terminal it resizes the window, losing whatever sizing adjustments I've made. How can I make it preserve the current window size when opening a new tab?

share|improve this question
    
Are you talking about creating a second tab in an existing window? That shouldn’t resize the window. If it does, please file a bug report developer.apple.com/bugreporter or provide feedback at apple.com/feedback/macosx.html – Chris Page Jul 4 '12 at 3:33
    
Which OS version? – Chris Page Jul 4 '12 at 3:34
1  
Yes, happens on creating the 2nd tab in any Terminal window. OSX Lion – Caffeine Coma Jul 5 '12 at 11:50
1  
This still happens to me on Mavericks. – Stefan Lasiewski Mar 5 '14 at 18:48
    
This happens to me in 10.10. Any solution yet? – Sam Pullara Oct 27 '14 at 4:35
up vote 5 down vote accepted

This behavior is due to the Window settings in Terminal. All new terminals open to what is specified under Window (default is 80 x 24). When you open a tab, it resizes the window to the new tab.

I wasn't able to find a solution to this for Terminal.app, however, I've since switched to iTerm 2, and it doesn't suffer from this issue. All new tabs open to the same dimensions as the existing window they're opened into, rather than resizing the window to the default.

You can find iTerm 2 at http://www.iterm2.com/

share|improve this answer
    
“When you open a tab, it resizes the window to the new tab.” If it does that, that’s a bug. I can’t reproduce it. What OS version? – Chris Page Jul 4 '12 at 3:36
2  
So iTerm2 is nice, but it has its own problems- page up/down and home/end do not work on a full-size keyboard. The solutions on iTerm's FAQ do not help. Frustrating. – Caffeine Coma Jul 5 '12 at 11:54
    
Chris, it happened to me frequently in Lion. I just tried it in Mountain Lion, and it doesn't appear to occur anymore. – billc Aug 12 '12 at 1:34
2  
This doesn't fix it for me. I'm using ML 10.8.4. Everytime I open a tab in terminal the window doubles in size. New windows are fine. – Rob Sep 9 '13 at 9:46
1  
Can confirm this is still a boss at being annoying. Mavericks OS. – Trip Apr 21 '15 at 16:13
  1. Open Terminal

  2. Click on Terminal on the menubar, go to Preferences

  3. Select Startup

  4. Change the option 'New tabs open with' to 'Same Settings'

share|improve this answer
2  
Already tried that- no effect. – Caffeine Coma Jul 2 '12 at 4:59
    
That’s the default setting. Was it not already that way? – Chris Page Jul 4 '12 at 3:35
1  
For future readers: When I changed the default columns under "Settings -> Window -> Window Size -> Columns" from 80 to 132, this worked. When I left it at 80, it would resize to 183 columns when I opened a new tab. So, maybe there's some automagic behavior with the default window size of 80 columns wide? – Walt W Jul 27 '15 at 21:04
    
+1 to @WaltW's comment. That's the solution that worked for me- It really out to be an answer so that it is easier for future readers to find. – Eliza Dec 14 '15 at 16:03

Resize your Terminal in Mac Preferences to fit your needs:

Open Terminal with Spotlight (⌘space, enter 'Terminal') and open Preferences (⌘,). In the Window tab, look at the Window Size, Columns & Rows. The values are often 80 and 24.

Optionally, resize your window to fix your desired new size. Pause and think, 24 lines, how wide is a line? OK, how many do I need?

Increase column size if when you both create a new tab or new window it is not the same size as your desired size.

Trial and error, just attempt to keep your estimates close and it will be brief. Similarly decrease if it is too large, for example, on this 1920 × 1200 scaled display the following is great for me: 130 & 40

Test your new setting by opening a new tab (⌘T).

Place your window over the previous one, is it the same size or close enough for you? If not keep resizing, until it is.

Open a new terminal window also (⌘N) and do similar.

Now consider using a window management program, I recommend Spectacle because it is free as in free beer and freedom: https://github.com/eczarny/spectacle

You can then use the following to move windows quickly while a window is selected: ⌘⌃→

This places the window in the top right corner 1/4 of the screen, left works similarly. If you also hold down shift it will place the window below in the 1/4 half of the screen: ⌘⌃⇧→

Plenty more options are available, enjoy!

share|improve this answer

While this is not a full solution but more of a workaround, I still thought it's worth sharing.

Like many on this thread, I noticed that, much to my annoyance, the Terminal window changes size when I add new Tab on El Capitan (10.11.3). I'm also using Spectacle for arranging my windows from the keyboard. I thought it might be an issue with spectacle but the same happens when I quit spectacle and resize Terminal windows with touchpad.

From what I noticed it only happens to me when when the below sequence is followed: 1. Open a new Terminal window 2. Add a new tab 3. Make the window smaller (height or width) 4. Add a new tab, and this one will change the size of the window.

Nothing happens when I make it bigger. I figured through experimentation that each and every tab in the window must be holding it's dimensions form when it was last viewed. In this particular scenario the last new tab in step 4 will change the size of the window to what it was when tab 1 was last viewed.

Now this is most important bit. The new tabs will adjust its dimensions to the biggest tab in the window.

Workaround: When I resize the Terminal window, I use Shift+CMD+Arrows to quickly browse through all the tab in this window. If I do that, new tabs will not affect the size of the window.

While it might be useful to some, I understand that it is not really practical, especially if you have a lot of tabs open. It is my way of dealing with this until a proper solution comes along.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.