Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

My MacBook Pro, for some reason, detects the wireless connection and I can open my Skype account without any problem BUT I cannot go to a web page. This happens on both Safari and Firefox. My HP computer is working fine on this network and has no problem going on the Internet!

I tried establishing a diagnosis and it says that apparently my connection is fine. I tried putting in a manual IP address but it didn't work so I don't know what to next! As far as I know I'm on 10.6.8, but I don't know which updates I've applied.

share|improve this question
    
Have you run the Network Assistant (in Preferences) already? Can you connect from iTunes (try accessing the store), does sending/receiving mail work? And I wouldn't recommend non-technical persons to mess with IP addresses. –  patrix Jun 30 '12 at 8:38
    
Open a Terminal.app, execute the following command and paste the results here: cat /etc/resolv.conf –  Martín Marconcini Jun 30 '12 at 9:03

1 Answer 1

up vote 6 down vote accepted

This is going to be a starting point answer, hopefully you can find something strange while comparing the shots and fix the problem.

If you can connect to Skype that means you have connectivity, but your computer is unable to perform name resolution (that is, convert the address of a service -like a webpage- to an ip address). Skype may work because it relies less on DNS and instead uses its own discovery protocol, or the entries that Skype requires may be saved from previous sessions.

In any case, start by going to System Preferences and typing DNS in the top right corner:

DNS note: the shots come from Lion (10.7.4), so you may see some differences

Now tap on Network (I believe Snow Leopard was the same).

You should be in a page that has multiple tabs, so let's see the important ones:

TCP/IP: let's see if you're using DHCP. If that's the case, then the DNS should be automatically set up for you, but this may not the working (some routers fail to provide this info or provide old info).

TCPIP

There isn't much to see here; I am using DHCP, so my network is automatically configured for me. Let's check the DNS.

dnstab

Now things get more interesting. I have two that correspond to OpenDNS (which you can use to test if you wish, they are free and open). One thing to note is that they are grayed out, meaning I can't change them. The reason behind this is because DHCP configured them for me. The real reason is because I have configured my router to provide these two DNS addresses to my computers and devices, so we all use a reliable service. But I could override this if I wanted by adding more (notice the plus symbol at the lower left corner). When you press that, you're given the option to type an IP address (use OpenDNS for this test or the Google servers: 8.8.8.8). Add just one, it's just a test.

While we are here, we can check one more thing, Proxies. Go to the proxies tab and make sure that -unless instructed by a crazy network administrator- everything is unchecked, specially the first two. Look at it:

proxies

All right, you're all set, go ahead and test your machine by opening Safari and typing www.google.com, performing a search and then testing any of the results.

What to do if this doesn't work?

Despite the above, things can still not work, so don't panic yet. If that's the case take some time to provide us with some details about your network, for example:

IP Address, Subnet Mask, Router, etc. etc. etc.

We can try to see what's going on from there.

share|improve this answer
2  
Hi Martin, THANK YOU so much for your answer you resolved my problem and the conclusion to the matter is "I am a crazy network administrator".Just joking but apparently in the proxys the HTTP and HTTPS were ticked, don't ask me why, I have no idea! Thanks to you, my internet connection works perfectly! You have truly saved me and you cannot imagine how greatfull I am. Plus you made it very easy to understand all the steps I really appreciate the time you took!Have a great weekend. Jessica –  Jessica Jun 30 '12 at 12:25
1  
This answer needs more upvotes. –  CajunLuke Jun 30 '12 at 15:10
    
Glad to hear it worked Jessica. Don't worry, we all have some Crazy administrator in us. Enjoy your connectivity! @CajunLuke thanks :) –  Martín Marconcini Jun 30 '12 at 15:47

protected by Community Nov 29 '12 at 6:11

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.