Ask Different is a question and answer site for power users of Apple hardware and software. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I need to transfer large files (9 GB) from my Mac to a PC. I bought a 64 GB flash drive, and it wouldn't work because it was in FAT 32 format and I couldnt transfer such a large file.

I reformatted the drive to ExFAT, and copied the file without a problem -- everything opened on my Mac and worked fine. When I plugged the drive into the PC, it said the drive was corrupted. So I went back to my computer, and the drive wasn't mounting. I opened Disk Utility and tried to repair it. After a while, it said it was repaired but the process never finished (even though it said in the activity log that it had been repaired). After an hour I pushed stop repair a few times, but it still didn't stop, so I just quit Disk Utility (probably not a great idea).

I decided to try starting again, and I clicked Erase in the Disk Utility so I can re-format the drive. Its now been about an hour and it hasnt moved past "unmounting disk" and the blue barber pole on the bottom.

Any ideas what I can do? Why did this happen? Should I just keep waiting? Should I quit Disk Utility? Any help or guidance would be incredibly helpful.

share|improve this question

Force-quit Disk Utility and yank the drive. OS X will probably fuss at you; ignore it.

Stick the drive into the Windows computer and format it there, using Disk Management. (I've had much better success with ExFAT drives formatted under Windows than under OS X.)

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.