Ask Different is a question and answer site for power users of Apple hardware and software. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Quite often my computer has trouble connecting to my home WiFi.

Sometimes once started, the computer does not find the WiFi on available networks. Sometimes it will find it, try to connect, then get "connection timeout" and WiFi disappears. Only way to fix it is shutdown and hope next time it will work.

During that time my iPhone is connected normally. This happens with both MBPs i got. Any suggestions as to what could cause this?

The router is d-link dsl-2640r

share|improve this question
Changing the channels seems to fix it for now. Didn't try it before as iPhone was working so I thought it has to be the MBP... – latusaki Jun 27 '12 at 20:17
It sounds like channel noise if that fixed it. If it happens again, try manually turning wifi off. Wait a few seconds and turn it back on. This has worked for me when my iMac and MBP have had similar issues. It's a pain I know. I only speculate that it has something to do with Apple trying to keep power consumption down. – ephsmith Jun 28 '12 at 1:33
The thing that doesn't fit in is why iPhone didn't lose signal tho. Maybe its working differently? – latusaki Jun 28 '12 at 10:03
I'm sure it's working differently and your Mac has a more powerful radio, which confuses the issue initially. Apple recently released updates which addressed issues related I wifi connectivity for Mac OS do it may just be related to their driver in general. If they are trying to throttle usage, the driver surely had to take some measurments of the amount of signal available from the router ad make a decision about how much power to use for communicating with it. – ephsmith Jun 28 '12 at 12:23
up vote 0 down vote accepted

I had a similar problem.

In my case when I pulled down the airport icon it saw the connection, but would then not connect. Along the way to not connecting it would ask me to enter my password. Even after entering the proper password it would not connect.

I finally solved the problem by going in to /Application/Utilities/Keychain and deleting my home wifi's stored password.

The next time I connected - it asked for the password and from that point on it has connected just fine.

share|improve this answer
Thanks for sharing. In my case the problem seems to be the WiFi channel. After changing it I haven't had a problem for few days now. – latusaki Jul 3 '12 at 22:09

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.