Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I'm using several virtual machines that take time to be paused when I want to reboot the system. It prevents OS X Lion from shutting down properly, because the VMware process is still running seconds after the reboot has been initiated. How can I tell OS X Lion to disable this shutdown interruption and simply wait for the process to be terminated? I know that I could manually pause the VMs before doing the reboot, but I really do want to change this behavior instead of using this kind of workaround.

share|improve this question
    
I've given you my thoughts. One approach that comes to mind (other than the obvious manual approach) is that there could be command-line tools for vmware that include shutdown commands. Maybe it would catch to those. –  ephsmith Jun 27 '12 at 17:13
    
I think what you really want here is to extend the timeout OSX has between the shutdown being requested, and it killing the shutdown because the apps haven't finished closing. –  Alex Jun 27 '12 at 17:16
    
Alternately, you could write your own shutdown script that first requested vmware to close, then triggered an OSX shutdown. –  Alex Jun 27 '12 at 17:16
    
Extending this timeout could help a lot. Now I'm facing this with VMware Fusion but it could be another app with heavy closing operations too. On Windows, there's a "WaitToKillServiceTimeout" registry tweak to avoid this problem, how about OS X? –  Laurent Jun 27 '12 at 17:43
    
It actually sounds to me like Lion is intentionally not killing applications during shutdown. Maybe it has something to do with versions and resume. –  ephsmith Jun 27 '12 at 17:47

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.