Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

All I am running OSX 10.6.8 I have enabled root login through Directory Utility. I have assigned a password.

I get an error when I try to ssh root@localhost.

ssh -v root@localhost

OpenSSH_5.2p1, OpenSSL 0.9.8r 8 Feb 2011
debug1: Reading configuration data /Users/rrazavipour-lp/.ssh/config
debug1: Reading configuration data /etc/ssh_config
debug1: Connecting to localhost [127.0.0.1] port 22.
debug1: Connection established.
debug1: identity file /Users/rrazavipour-lp/.ssh/identity type -1
debug1: identity file /Users/rrazavipour-lp/.ssh/id_rsa type 1
debug1: identity file /Users/rrazavipour-lp/.ssh/id_dsa type 2
debug1: Remote protocol version 2.0, remote software version OpenSSH_5.2
debug1: match: OpenSSH_5.2 pat OpenSSH*
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_5.2
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug1: kex: server->client aes128-ctr hmac-md5 none
debug1: kex: client->server aes128-ctr hmac-md5 none
debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
debug1: Host 'localhost' is known and matches the RSA host key.
debug1: Found key in /Users/rrazavipour-lp/.ssh/known_hosts:47
debug1: ssh_rsa_verify: signature correct
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug1: SSH2_MSG_NEWKEYS received
debug1: SSH2_MSG_SERVICE_REQUEST sent
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug1: Authentications that can continue: publickey,keyboard-interactive
debug1: Next authentication method: publickey
debug1: Offering public key: /Users/rrazavipour-lp/.ssh/id_dsa
debug1: Authentications that can continue: publickey,keyboard-interactive
debug1: Trying private key: /Users/rrazavipour-lp/.ssh/identity
debug1: Offering public key: /Users/rrazavipour-lp/.ssh/id_rsa
debug1: Authentications that can continue: publickey,keyboard-interactive
debug1: Next authentication method: keyboard-interactive
Password:
debug1: Authentications that can continue: publickey,keyboard-interactive
debug1: Authentications that can continue: publickey,keyboard-interactive
debug1: Authentications that can continue: publickey,keyboard-interactive
debug1: No more authentication methods to try.
Permission denied (publickey,keyboard-interactive).

What I am doing wrong? I know I have the password correct.

share|improve this question
    
Is there a specific reason you are logging in via ssh instead of just using sudo su? –  ephsmith Jun 27 '12 at 2:22
add comment

1 Answer 1

Root login over SSH is not enabled by default for good reason. Since you are not connecting remotely in your example, I recommend:

sudo su

to switch to root user if you need to run several commands in a row. This keeps you from needing to do the much safer

sudo commandname

where you need to prefix every command with sudo. If ssh is a requirement, you can simply:

ssh user@host

and then

sudo su

to switch to root user. This is a much safer approach from a security standpoint.

Lastly, if you really think you must enable root login over ssh, see this link for instructions.

share|improve this answer
    
I need to do this because I am testing/developing an NKE. –  reza Jun 27 '12 at 15:16
    
@reza , any of these approaches should solve your problem. I was merely cautioning against enabling remote root login. Can you explain how being logged in as root directly relates to developing and NKE? ssh user@host followed by sudo su gets you root access and its safer. –  ephsmith Jun 27 '12 at 15:21
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.