Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

If I try to navigate to any of the following pages:

I get an error message in Safari saying:

Safari can't open the page "https://encrypted.google.com/" because Safari can’t establish a secure connection to the server "encrypted.google.com"

I also find that on the Gmail page many images are missing and when I try to go the image location I see the same error as above. Here's a pic of the missing images:

enter image description here

In chrome I have the same issue but with a different error as follows:

Error 107 (net::ERR_SSL_PROTOCOL_ERROR): SSL protocol error.

I am not using a proxy and this behaviour has started recently for seemingly no apparent reason although I did get a new router about 2 weeks ago. Why am I experiencing these problems?

share|improve this question
    
Couple things to check. 1. Did you visit China recently? 2. What version of Mac OS X? 3. DNS servers, what are they? 4. Version of Chrome? Version of Safari? My first thought is that there is some redirection going on when you visit those named domains, which could be related to DNS. second would be invalid certs. –  Greg Nov 17 '13 at 8:18
    
I don't know if this is related to your issue or not, but there has been a lot of chatter in security circles about SSL/TLS issues lately (and not just Apple's problem.) Many servers have been reconfigured to stop supporting a lot of older configurations known to be insecure, and I expect there to be issues where SSL/TLS just plain won't work for at least a little while. –  zigg Mar 20 at 11:16
add comment

Know someone who can answer? Share a link to this question via email, Google+, Twitter, or Facebook.

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.