Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I am trying to install the rpm package using MacPorts, but this is what I get:

~ wdb$ sudo port install rpm
--->  Computing dependencies for rpm
Error: org.macports.activate for port rpm returned: error renaming 
"/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_sysutils_rpm/rpm/work/destroot/opt/local/lib/python2.5/site-packages/rpm"
 to 
"/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_sysutils_rpm/rpm/work/destroot/opt/local/Library/Frameworks/Python.framework/Versions/2.5/lib/python2.5/site-packages/rpm": no such file or directory

Please see the log file for port rpm for details:
/opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_sysutils_rpm/rpm/main.log
To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets
Error: Processing of port rpm failed
~ wdb$ 

What is the exact problem? How can I fix it?

share|improve this question
1  
Just a sanity check. Did you assure that your ports install has been updated with port selfupdateetc? –  ephsmith Jun 26 '12 at 14:11
    
@ephsmith yes, I did. –  Wim Deblauwe Jun 26 '12 at 14:22
    
I would ask on the macports development list - given the python2.5 and perl5.8 dependencies I would guess this is an old port and needs to be redone –  Mark Jun 29 '12 at 22:52

1 Answer 1

up vote 2 down vote accepted

This is a bug in the rpm port. I have filed bug report 35048 for you. I've also listed a workaround there and described how the maintainer of the port can fix it so the workaround is no longer needed.

The workaround is to install from source:

sudo port -f uninstall rpm
sudo port clean rpm
sudo port -s install rpm
share|improve this answer
    
The bug is marked as fixed, but what do I need to do to get that version on my system? –  Wim Deblauwe Jul 2 '12 at 7:05
1  
@WimDeblauwe run sudo port selfupdate to get the latest port metadata and then do the port install –  Mark Jul 6 '12 at 12:05

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.