Ask Different is a question and answer site for power users of Apple hardware and software. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've had on Lion (and previously Snow Leopard) successfully working with my company's Exchange 2007 for the last couple of years, but today it seems like it's decided not to work. Instead, I get an error message in the UI that it was unable to connect, and in, the only related message I get seems to be:

25/06/2012 12:32:01.490 Mail: [<_LibSasl2SASLClient: 0x7fcb2944de10> mechanism:
PLAIN security layer: no] Failed to start the SASL connection
SASL(-1): generic failure: 

And that's all. The connection does work with Outlook, however. A Google search hasn't turned up anything useful. Any thoughts on where I can go with this? Unfortunately our IT team doesn't support (only Outlook) and they're even reluctant to support Lion, so they won't be much help, and I'd really rather use than that horrible bloatware.

share|improve this question
Have you tried deleting the account and adding it back? This has worked for me in the past. – ephsmith Jun 25 '12 at 12:32
Yeah, done that twice. My iCal isn't working either. It all works on my iPhone though. So puzzling. – Jonathan Jun 25 '12 at 13:43
I've run into the same bit of confusion before when my iPhone was able to connect and my MB was not. The iPhone connection uses ActiveSync and uses Exchange Web Services. Unless the problem on your IT end affected both, you wouldn't have noticed it on your iPhone. – ephsmith Jun 25 '12 at 18:46

It looks like this was some kind of configuration problem on the Exchange server. It was resolved by my IT team. Unfortunately I don't have any more details than that.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.