Ask Different is a question and answer site for power users of Apple hardware and software. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have recently moved my blog to another hosting company. The problem is that I cannot access my blog from my macbook pro although at the same time I can see it from my sony vaio. Going at the terminal and running : nslookup I get the following results:

Server: Address:

** server can't find NXDOMAIN

(Server is my isp's domain name server)

Any ideas how to fix that error so that I am able to access my blog from my macbook pro? Thank you!

PS : My operating system is MAC OS 10.7.4

share|improve this question
up vote 1 down vote accepted

Try using dscacheutil -flushcache in the terminal on the Mac.

share|improve this answer
I just tried it but I still cannot access my blog.Thank you for your answer anyway. – skiabox Jun 22 '12 at 15:15
Perhaps your dns server has the NXDOMAIN still in the cache. Check if you can resolve the IP by using: "host" If so, don't worry, NXDOMAIN isn't cached for very long anyway in most cases. – mdrozdziel Jun 22 '12 at 15:17
I tried your host command ( is google dns?) and I get the following result -> Host not found: 3(NXDOMAIN) – skiabox Jun 22 '12 at 15:21
I don't know if that matters, but I connect my macbook pro wirelessly to an airport express (that is connected to the router) and the sony vaio wirelessly to the router. – skiabox Jun 22 '12 at 15:37
It seems that it was a matter of time as you say in your second comment! :) Everything works fine suddenly. – skiabox Jun 22 '12 at 16:56

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.