Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Help!

Spotlight stopped working ... if I go to spotlight search (top right), it just hangs.

Same with Apple-F in Finder ... it causes Finder to hang for a minute or so. Cannot search.

I went to Spotlight Sys Prefs. Switching to Privacy Tab takes like 10 seconds. Then If I try to add a drive to Privacy tab, it either crashes SysPrefs, or gives me this:

enter image description here

So I tried all kinds of things I found online, like

sudo mdutil -a -i off
sudo mdutil -i on
sudo mdutil -a -E -v
sudo launchctl unload -w /System/Library/LaunchDaemons/com.apple.metadata.mds.plist
sudo launchctl load -w /System/Library/LaunchDaemons/com.apple.metadata.mds.plist
sudo mdutil -aEv

sudo rm -rf /.Spotlight-V100
sudo rm -rf /Volumes/0/.Spotlight-V100

etc...

I tried rebooting from a backup System drive & repairing permissions from Disk Utility.

But it still doesn't work!

Help! OSX 10.6.8


Update: some more weirdness: The plist for mds tries to launch /System/Library/Frameworks/CoreServices.framework/Frameworks/Metadata.framework/Support/mds

But if I look inside /System/Library/Frameworks/CoreServices.framework/Frameworks/Metadata.framework/

I see that Support is just a hardlink to Versions/Current/Support

Support -> Versions/Current/Support

Then looking inside Versions I see only one folder called A and inside that are Headers, Metadata, Resources, Support -- and inside Support is: mds,mdworker,mdworker32,mdwrite

Should I edit my com.apple.metadata.mds.plist to launch /System/Library/Frameworks/CoreServices.framework/Frameworks/Metadata.framework/Versions/A/Support/mds ??

What the heck is this A folder???

share|improve this question
    
Does anything interesting show up if you search for md or spotlight in system.log in Console? –  Lauri Ranta Jun 22 '12 at 7:47
    
Yes, actually! This repeats over and over: com.apple.launchd[1] (com.apple.metadata.mds[31908]): posix_spawn("/System/Library/Frameworks/CoreServices.framework/Frameworks/Metada‌​ta.framework/Support/mds", ...): No such file or directory com.apple.launchd[1] (com.apple.metadata.mds[31908]): Exited with exit code: 1 com.apple.launchd[1] (com.apple.metadata.mds): Throttling respawn: Will start in 10 seconds –  Ze'ev Jun 22 '12 at 8:02
    
But it stops after I do sudo launchctl unload -w /System/Library/LaunchDaemons/com.apple.metadata.mds.plist –  Ze'ev Jun 22 '12 at 8:06
    
Frameworks can contain multiple versions in directories like A, B, etc. com.apple.metadata.mds.plist should already launch mds. Can you try upgrading to 10.7 or upgrade installing 10.6 again? –  Lauri Ranta Jun 22 '12 at 8:42
    
What does ls -l /System/Library/Frameworks/CoreServices.framework/Frameworks/Metadata.framework show? –  Mark Jun 22 '12 at 11:35
show 1 more comment

closed as unclear what you're asking by bmike Jan 6 at 21:13

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question.If this question can be reworded to fit the rules in the help center, please edit the question.