Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I have an iPhone 4S. No Facebook push notifications are activated on my phone. Nevertheless, several times a day I receive a push notification that I have been invited to X event or Y person is in my vicinity. I can't seem to figure out why I'm receiving these notifications and I would rather not get them. Any clue what's behind this mystery?

share|improve this question
    

2 Answers 2

The answer Matthew Frederick gave should do the trick, but if you want to disable them from within the Facebook app itself, the alternative approach is to:

  1. Open the Facebook app
  2. Press the button in the upper left and scroll down to Settings
  3. Select Account Settings
  4. Select Facebook Notifications
  5. Select Push Notifications
  6. Uncheck any of the four boxes there

    • Close Friends List Activity
    • Group Posts and Comments
    • Tags You in a Post
    • Mentions You in a Comment

If you are receiving additional notifications, they may be coming from the Facebook Messenger app which is separate from the main Facebook app and I believe has it's own settings for push notifications relating to private messages.

share|improve this answer
    
Facebook Messenger is only about private messages. Groups and Events messages are still in the main app. I've updated your answer accordingly. Feel free to edit/rollback if I'm mistaken. –  Loïc Wolff Jun 22 '12 at 8:06
    
A ha. This looks like it could be the solution. If I don't get any FB push notifications within the next 24 hrs I'll mark this correct. –  samthebrand Jun 22 '12 at 12:50
    
Odd that you have to disable FB push notifications in 3 separate places... –  samthebrand Jun 22 '12 at 12:53
    
Totally bizarre that they'd override the OS settings for the app. Wrong, even. –  Matthew Frederick Jun 22 '12 at 17:07
    
After disabling all push notifications in the app (and in the OS AND in the notification center), I'm still getting notifications. Think I'm out of ideas here. I'm restarting the phone... maybe that will do the trick. –  samthebrand Jun 22 '12 at 17:45

When you say that none are activated on your phone, do you mean in the Facebook app or in Settings?

To check, go to Settings->Notifications, and then scroll down to the Facebook item and tap it. Make certain that you have both "Notification Center" set to "Off" and have "Alert Style" set to "None".

share|improve this answer
    
Thx Matthew, but the settings you mention are already enabled. –  samthebrand Jun 22 '12 at 4:08

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.