Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

When I plug in a USB drive while my VM is running, Parallels offers a dialog lightbox asking whether the USB drive should associate with the Mac or the VM. Once this choice is made, Parallels tends to remember/respect it on every subsequent reconnect. Sometimes I want to change this association, but I don't see how I can. Is there an easy option to change the USB drive's association on the fly? Or do I need to select something to make Parallels forget all USB associations and start over?

Dialog lightbox

share|improve this question
    
Do you hold Option (alt) to remember the choice? If you don't, it should ask every time. –  CajunLuke Jun 21 '12 at 22:42
    
I don't hold down alt, but it remembers anyway –  Sean Jun 21 '12 at 22:43
    
That sounds like a bug in Parallels. Have you asked their support about it? –  CajunLuke Jun 21 '12 at 22:44
    
Nope—thought I'd try here first. I will –  Sean Jun 22 '12 at 2:33

2 Answers 2

up vote 3 down vote accepted

I had the same problem, with a USB disk drive. Parallels was configured to ask each time yet always put the device to the guest I'd first used it on. Choosing Parallels Preferences didn't help. The device wasn't listed as one that had a permanent assignment.

I think this is expected behavior as the documentation talks about a "New" device.

The fix for me was to Option-click (Alt-click) the Parallels icon in the Dock and choose Devices -> USB and there I saw the device listed with a tickmark next to it. Selecting the device removed the tickmark. Next time the devise was connected I was asked.

share|improve this answer

Even though you aren't telling it to remember devices, you can remove any 'permanent' assignments by following this guide. This should list all the devices for which it remembers Host vs VM assignments

Specifically:

1. Do one of the following:
    Option-click (Alt-click) the Parallels icon in the menu bar and choose Preferences.
    If the Parallels Desktop menu bar is visible at the top of the screen, choose Parallels Desktop > Preferences.
2. Click USB.
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.