Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I've been using Command ⌘+1~4 shortcuts for switching spaces on older versions of OS X.

But after upgrading to Lion (10.7.4), Command ⌘+3 and Command ⌘+4 do not work!

I need them to switch tabs in web browser and they are very useful shortcuts in Xcode too.

I looked in Keyboard in System Preference but couldn't find where they are defined.

Command ⌘+1 and Command ⌘+2 work in both Chrome and Xcode. (Command ⌘+5~6 works also)

I don't know why Command ⌘+3 and Command ⌘+4 do not work in any application!

My guess is they're defined for something else globally. But I can't find where.

Another guess is they're probably defined for 'Switch to Desktop 3, 4' since I've been using old version of OSX and upgraded to Lion.

Like DMan pointed out, after removing 'Switch to Desktop 1, 2', Command ⌘+1 and Command ⌘+2 work just fine.

But where's 'Switch to Desktop 3 and 4'??

share|improve this question
    
I don't have Lion but you can switch tab with ctrl + tab. –  benoît Jun 21 '12 at 7:27
    
Switching tabs in what? A browser? Safari has never supported command 1~0. Chrome and Xcode do work as you've indicated. –  Jason Salaz Jun 22 '12 at 0:11
add comment

1 Answer

up vote 1 down vote accepted

Try this:

  1. Open System Preferences -> Keyboard
  2. Click the Keyboard Shortcuts tab.
  3. From the left column, choose Mission Control.
  4. In the Pane on the right, you should be able to re-set the keyboard shortcuts for your spaces.

enter image description here

share|improve this answer
    
Thanks. I see Cmd+1, Cmd+2 are defined for 'Switch to Desktop 1, 2'. I disabled them. But where's 'Switch to Desktop 3 and 4'?? –  SeniorLee Jun 22 '12 at 0:53
1  
I believe the options for 'Switch to Desktop N' appear once you have N spaces added via Mission Control. –  noffle Jun 22 '12 at 5:57
    
GOD! You're my saviour, noffle!! Thank you so much!! Everything works just fine!! –  SeniorLee Jun 22 '12 at 8:11
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.