Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I have Snow Leopard Server 10.6.8 running in a VMware Fusion 4.1.3 virtual machine. When I run a Disk Utility "Verify Disk" from within the VM, errors are reported.

Invalid B-tree node size

The volume could not be verified completely.

Error: This disk needs to be repaired. Start up your computer with another disk (such as your Mac OS X installation disc), and then use Disk Utility to repair this disk.

I have successfully mounted the .vmdk volume using VMDKMounter.app (from Fusion 3) after installing Fuse for OS X 2.4.2.

The problem is that both Disk Utility & Disk Warrior want to unmount the volume before making repairs. Both apps then produce error dialogs.

Is there a way of running these utilities on a Fusion volume?

share|improve this question
add comment

1 Answer

Both Disk Warrior and Disk Utility will work on a .vmdk mounted volume using the VMDKMounter.app IF the .vmdk is not damaged.

I created a new .vmdk, recopied the drive image and both Disk Warrior 4.4 and Disk Utility worked fine.

It appears that if the .vmdk becomes damaged somehow, the normal tools I use will not work.

Keeping good backups appears to be even more important when you add Virtual Machines to the mix.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.