Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

It seems my Safari is not resuming correctly.

I open some tabs, then quit and when fire up Safari again it's opened like wasn't have any tabs opened before.

Is it some version bug, or i should look for something in Safari prefs?

  • Safari 5.1.7 (7534.57.2)
  • MOX 10.7.4 (Build 11E53)

EDIT: In reaction to Michiel i've checked whether i have Resume turned on. System preferences -> General

share|improve this question
    
Is restoring windows when quitting and re-opening apps unchecked in the general preferences? Does defaults read com.apple.Safari NSQuitAlwaysKeepsWindows return 0? –  Lauri Ranta Jun 19 '12 at 8:33
    
git.io/csCr6w -- is there some clean way to fix it? I don't want to do it via shell –  Mailo Jun 19 '12 at 8:48
    
I just thought NSQuitAlwaysKeepsWindows might have been set to false. But since there was no key for it, it's something else... –  Lauri Ranta Jun 19 '12 at 9:05
add comment

3 Answers

up vote 1 down vote accepted

Now it's working again.

Steps i did:

  • Disable and Enable again resume in System preferences → General
  • Enable and Disable again extensions in Safari → Preferences. I don't have any extensions installed. The "abling" was just about the Safari's functionality Abling Extensions in Safari

I don't know what of these steps fixed it, but now it simply works :/

P.S.: Back to Lauri Ranta's check. It has still same result

defaults read com.apple.Safari NSQuitAlwaysKeepsWindows                                                                                                                     
2012-06-19 11:13:35.069 defaults[2240:707] 
The domain/default pair of (/Users/mailo/Library/Preferences/com.apple.Safari.plist, NSQuitAlwaysKeepsWindows) does not exist
share|improve this answer
add comment

It's not a setting in Safari, but a general setting. Go to your System Preferences < General and make sure Restore windows when quitting and re-opening apps is checked on.

enter image description here

But you can install some 3th party apps too.

  • There is SafariRestore, which will basically do the same. But you have to disable the Restore windows when quitting and re-opening apps on the screenshot above!
  • You can also add the Sessions extension to Safari which will do the same.

I haven't any experience with neither of these apps, so please let me know if it works out!

share|improve this answer
    
Unfortunately i have it enabled (see updated question) –  Mailo Jun 19 '12 at 8:45
    
Hmm, that's odd. It works for me with great ease. I'll check for more solutions... –  Michiel Jun 19 '12 at 8:51
    
Last week or so it was working for me also –  Mailo Jun 19 '12 at 8:59
    
What did you do in the mean time? (Install or delete something?) –  Michiel Jun 19 '12 at 9:01
1  
I found a questionable fix. Now it works, but thank you. The only thing which could cause this, could be the recent Safari update. I wasn't doing any system invasive stuff for a long time, maybe for all the time i have it installed ;) –  Mailo Jun 19 '12 at 9:19
show 2 more comments

I found another workaround, although I'm not sure why this worked or even if it actually worked or was simply a coincidence.

What I did was: Restore Safari (in the main Safari menu). I had every box checked except the ones about location and saving passwords. So it was sort of an "erase". Then I quit Safari en started it again. Now it works again, correctly resuming all tabs I had open.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.