Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I accidentally deleted the files in /etc/ (yes into /private/etc) and my iMac gets stuck on a blue screen after the initial apple logo now. I tried to boot from install DVD but it hangs at the apple logo when I do that.

Any suggestions on how to fix or reinstall the OS?

This is an iMac with OS X Snow Leopard.

share|improve this question
add comment

2 Answers

See Startup key combinations for Intel-based Macs (HT1533) for a list of available key combinations during startup. In your case you should use either of

  • C: Start up from a bootable CD, DVD, or USB thumb drive (such as OS X install media)
  • Option ⌥: Start up in Startup Manager, where you can select an OS X volume to start from. In your case the volume to select is the OS X Snow Leopard DVD
share|improve this answer
    
mentioned that i tried booting from DVD already, hangs at apple logo. The only non-regular mode I can boot into is single-user root mode. –  davidosomething Jun 20 '12 at 17:00
add comment

My iMac would loose its boot sequence because I had it booting into Windows mode. What Apple told me to do was to hold down the Option ⌥ key while the machine was rebooting.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.