Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

My email replies default to my Gmail account even though the "from" line and the "default account" in the Settings are my main (preferred) account address. How do I fix this?

share|improve this question

3 Answers 3

If you're in an account's Inbox, it'll send from that account. Go to the All Inboxes general inbox or the main account-selection screen to hit the "Compose new email" button.

share|improve this answer
    
It's puzzling, but the problem persists. I'm thinking to delete Gmail and see is the "default account" becomes the one selected. Any other ideas? –  Nutnelson Jun 18 '12 at 19:30

In brief, though this isn't an Apple-specific answer, check your settings to see what SMTP servers (not POP3 or IMAP4) you're using and see if it isn't gmail. I'm pretty sure if you use Gmail to send an email, the return path is set to that gmail account. This helps bring down the usefulness of a zombie Gmail account for spammers.

See a little bit about From, Reply-To, and Return Path here.

The deal is that the server stamps the Return Path; it's not something you can edit with your mail handler. As the above post says, Return Path isn't a client-set header.

So to build off of @CajunLuke, if you're reading an email that went to your Gmail account in Mail, then reply using, by default, Gmail, even if you have From and Reply-To set to My.Real.Email@example.com, you'll receive replies via a return path set for Gmail (depending on the replyer's mail hander).

Note that anything sent with Gmail's SMTP server will return path to your gmail account. If you use Gmail's SMTP server as your default SMTP server, it'll stamp that gmail return path no matter what your client uses as its mail headers. Try another SMTP server as your default and see if that doesn't work.

Iirc. IANAL. ;) I do recall having a similar problem with Gmail as the default SMTP server [for me, on Thunderbird, but it's the same in Mail.app].

share|improve this answer
    
I think you nailed it! My primary server needs to be reconfigured and the other SMTP server (Gmail) was being used. Thanks a million. –  Nutnelson Jun 18 '12 at 19:43
    
I think this is where I selfishly say, "If that worked, and you don't mind, click the check to accept the answer" -- and if it didn't, give me a yell too. ;^) –  ruffin Jun 18 '12 at 20:46

It's a known bug introduced in Mountain Lion and was submitted to Apple by several people. Mail ignores the Send new messages from: Account of selected mailbox setting.

See for example:

I submitted the bug and is now marked as duplicate (but Apple's reporting tool does not allow you to see the duplicated entry).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.