Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I have a Wifi-only new iPad, which uses an Exchange-type account for my Gmail. It connects just fine when I'm at home. But the last time I was out and about, I found I had a new email, but only the title and sender appeared in the Mail app. I had to connect the iPad to a public Wifi network to download the whole email.

How can I force the iPad to always download the whole email message (attachments can wait) so I can read the whole message when I have time?

share|improve this question
    
Do you get the message in the body of the email that says "This message has not been downloaded from the server"? –  bassplayer7 Dec 19 '12 at 19:10
    
Yep. And it tantalizingly shows the email title in Notifications, but I can't read the body. –  KatieK Dec 19 '12 at 19:12
    
You might need to perform a test, but how long between when you receive (as in receive, not when the email was sent) the email, and when you disconnect from the internet? –  bassplayer7 Dec 19 '12 at 19:25
    
Were you able to test it? I ask because my wifi only iPad normally downloads all the email, and it is only if I disconnect from wifi immediately after an email comes in that it doesn't. In fact, normally even images in the emails download. –  bassplayer7 Dec 20 '12 at 23:20
    
I didn't have the time to test last night, but it's on the list. I assume you're using Mail? –  KatieK Dec 20 '12 at 23:35
show 1 more comment

2 Answers

up vote 1 down vote accepted
+50

Exchange ActiveSync 12.1 (introduced with Exchange Server 2007 SP1, released in Nov 29 2007) added a policy called mail body truncation size (see http://en.wikipedia.org/wiki/Exchange_ActiveSync#Exchange_ActiveSync_12.1).

This is a server-side policy that can be enforced for a group of users, as stated in the Microsoft Exchange documentation (see http://technet.microsoft.com/en-us/library/bb123484%28v=exchg.80%29.aspx):

Exchange ActiveSync mailbox policies let you apply a common set of policy or security settings to a user or group of users.

(...)

Maximum HTML e-mail body truncation size

This setting specifies the size beyond which HTML-formatted e-mail messages are truncated when they are synchronized to the device. The value is specified in kilobytes (KB).

(...)

Maximum e-mail body truncation size

This setting specifies the size beyond which e-mail messages are truncated when they are synchronized to the device. The value is specified in kilobytes (KB).

IBM Lotus Notes Traveler, which supports ActiveSync starting with version 8.5.1, has a similar setting in Default Preferences>Sync settings (see http://infolib.lotus.com/resources/domino/traveler/8.5.3/doc/ta853abd002/nl_be/NotesTraveler.html#Downloading_truncated_e-mail_message):

Email Body Truncation

Enables email body truncation. Characters beyond the default character value in the email body are truncated from the email body.

So it looks like it is a bandwidth-saving setting on the server and you basically can't do anything about it.

share|improve this answer
    
I wonder if Gmail's servers are set like this? –  KatieK Dec 20 '12 at 17:05
add comment

Settings/Mail, Contacts Calendar

Under the mail area, change the "show" messages to maximum Under each account change "mail days to sync" to "no limit"

This should help, as for attachments, I'm trying to solve the same issue. Thinking the only answer for me is using Sparrow mail (I'm a gmail user).

share|improve this answer
5  
Are you sure that the whole message gets downloaded if you increase the number of messages to download? –  patrix Jul 7 '12 at 18:20
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.