Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I'm having issues with my just-purchased Time Capsule (2 TB). I have it in my room connected wirelessy to an existing network. I think this means I'm not taking full advantage of 802.11n, right? I'm doing the intial backup of some files. It is taking 20+ hours to transfer 40GB of data.

I expected the wireless transfer to be slow, but not so much! So I tried to connect to the Time Capsule from my MacBok Pro via Ethernet, but the connection speed didn't change, and this left me wondering: shouldn't be the connection via Ethernet be way faster? What is the proper way to configure this?

share|improve this question
add comment

2 Answers

up vote 3 down vote accepted

If you connected the Ethernet cable while the backup was running, it is probably still utilizing the wireless interface. It can not re-route an established connection in the middle of the backup.

Start by cancelling the backup. Then do one of the following:

  • Disable the Wi-Fi interface on the computer; OR...
  • Open Network in System Preferences; click on the cog button below the list of network interfaces; click on "Set Service Order"; drag the services so that Ethernet is on top of the list; click OK and Apply.

Now, restart the backup.

share|improve this answer
1  
Thanks for this comment, helped me to move interfaces so ethernet is most important above wifi :) –  Rob Mar 18 '13 at 16:34
add comment

It may also be a network problem.

You said you connected the Time Capsule to an existing network: what kind of network? To use WiFi "n", your wireless access point (generally, your router) has to support WiFi "n" too. Also, even when using WiFi "n", depending on your router (and its antennas) you may get different speeds, from 300 mbps to 450 mbps. Last thing about the WiFi connection: the channel you are using may be "congested". This is especially possible if your neighbors have WiFi networks too. You may want to try with a different channel (you can change that in your router's settings panel).

About ethernet... Did you connect your Mac to the Time Capsule directly? If the Time Capsule is connected to a network, you should never connect to it directly (it won't work as you expect!). That may also explain why you are not seeing differences in speed: your Mac was still using WiFi to connect to the Time Capsule.

The best thing to do, in my opinion, is to connect the Time Capsule to the network via gigabit ethernet.

First of all:

  1. Make sure you have a router with gigabit ethernet ports (or it will be actually slower than WiFi "n"!)
  2. Make sure your cables can support gigabit ethernet (have to be "class 5e" or higher, preferably)

Then, connect the Time Capsule to the router via cable. You may then connect to it using either your existing WiFi network or via gigabit ethernet (plug the cable into the router, not into the Time Capsule!).

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.