Ask Different is a question and answer site for power users of Apple hardware and software. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am using a Unibody MacBook Pro on Lion. I am trying to add a networked printer at work so I can print to it, but OS X is not cooperating with me.

Typically for adding networked printers on a Windows network, most instructions online suggest you open the Print & Fax preference pane, hit the + button to Add Printer, then use the Advanced tab to select the type of networked printer, and type in a specific URL to reach it.

I would like to follow these steps, but I am unable. As you can see in the screenshot below, everything under the Advanced tab in the Add Printer window is disabled.

Add Printer window, with the Advanced tab selected.

I don't understand how or why this is. My user definitely has full administrator privileges, and this tab of all the others in the dialog should be open-ended and allow you to type and search for printers to add regardless of environment, or perhaps what OS X may have already detected as plugged-in or over Bonjour.

I have searched the web for any indication of why this area of my Add Printer dialog is unusable, but have not been able to find any clues. Any tips to get this thing unstuck are appreciated.

P.S. My connection to the Windows network at work seems to be fine. I am able to mount and use several of the shared network drives over SMB.

share|improve this question

Hey I ran into the same problem. If you turn off System Preferences -> Sharing -> Printer Sharing the advanced tab becomes enabled again.

share|improve this answer
Worked for me, thanks. – Mike Weller Jul 26 '13 at 7:56
Also fixed it for me, not only in advanced but even the "Use" entry under the "Default" tab. It's utter nonsense that a USB printer can't be added while Sharing is enabled. – Justin Searls Dec 2 '14 at 0:36
Great tip! "Printer sharing" was off, but I also turned off "File sharing", then turned "Printer sharing" on and back off... one of these somehow did it! Weird that (still, in 2015) it's just disabled with no warning about how to reverse it... – alexis Apr 21 '15 at 14:15


smb://workgroup/server/sharename smb://server/sharename

share|improve this answer
Also if you need to authenticate you may have to do username:password@ after smb:// – Gregory Muchin Jun 16 '12 at 15:22

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.