Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

When I start the X11.app then it launches an xterm automatically. I've long since switched from the "ordinary" xterm to rxvt-unicode so the initial xterm just hangs around like a wallflower never being used. Whilst it's not particularly bad, it spoils the look of the place so I'd like to stop it launching. How do I do it?

share|improve this question

1 Answer 1

up vote 8 down vote accepted
defaults write org.macosforge.xquartz.X11 app_to_run /usr/bin/true

in a Terminal. However, note that there really shouldn't be necessary to every start XQuartz.app (or X11.app; see the comments) manually. It will start automatically when you run an X11 client, and then it will not start its defaults startup application.

share|improve this answer
    
Uh, sorry, I hadn't noticed that you use X11.app. Don't do that. Use XQuartz for all your X11 needs on the mac. That said, I think X11.app has the same defaults setting, but I don't remember the name of the preferences file. Look for it in Library/Preferences/. –  Harald Hanche-Olsen Jun 14 '12 at 18:44
    
Last time I used Mac OS X then XQuartz wasn't around so I hadn't heard of that - any other things like that I should know about? For X11 it's org.x.X11, and I set the value to '' which seemed to work as well as /usr/bin/true. –  Loop Space Jun 14 '12 at 18:48
    
Hmm. No, I can't think of anything other than X11/XQuartz with that particular peculiarity. Though I remain forever confused about whether I should get my Java updates from Apple or Oracle these days. –  Harald Hanche-Olsen Jun 14 '12 at 18:52

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.