Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

For some reason, since Monday iMessage on the iPhone 4S always tells me it couldn't deliver my message but the messages go through. Anybody have the same problem? Any idea how to fix it? I'm not the only one, a couple friends have it too, but Google didn't help.

share|improve this question
1  
I've noticed this occasionally myself. Does it happen on every text? Have you rebooted the phone(s)? –  bassplayer7 Jun 14 '12 at 18:42
    
Yes it does and yes I did, didn't fix it :-( –  Volker Bach Jun 15 '12 at 8:18
1  
Does it happen on every kind of network? (3G, WiFi, ...) What are the similarities and the differences between your and your friends' phones? (same iPhone, same network, ...) –  Loïc Wolff Jun 15 '12 at 9:30
    
3G and Wifi, 2x 4S, 2x 3GS, three of which are on T-Mobile (Germany), the other one is on E-Plus (also Germany) –  Volker Bach Jun 15 '12 at 20:56
    
That's not fixable unless you have a very stable connection with Apple's server with little ping. –  Shane Hsu Mar 29 '13 at 12:41
add comment

2 Answers

Apple has a status page to show availability of all the different services: Apple System Status. Worth checking in these moments, it doesn't always look like

enter image description here

share|improve this answer
add comment

Ok, so it's official, it's not a bug, it's a temporary problem with iCloud service.

http://www.heise.de/mac-and-i/meldung/iCloud-Dienste-und-iMessage-zeitweise-gestoert-1622986.html (in german, english as translated by Google)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.