Ask Different is a question and answer site for power users of Apple hardware and software. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I want to prevent the user from being able to stream to remote speakers with any client on their laptop. Is there a way to globally disable AirPlay on a Mac OS X (10.6 or 10.7) system?

share|improve this question
By disabling you mean you want to prevent any user from selecting a remote speaker in iTunes? – patrix Jun 13 '12 at 15:41
I want to prevent the user from being able to stream to remote speakers with any client on their laptop. – Freyday Jun 13 '12 at 16:01
Please don't post the same question on different SE sites. – vcsjones Jun 13 '12 at 16:09
AirPlay is part of Bonjour, which you probably don't want to disable. – vcsjones Jun 13 '12 at 16:11

It appears you can use managed preferences (MCX) to disableAppleTV:


..but that will only affect iTunes, and I don't have an AppleTV on hand to test.

share|improve this answer

Unfortunately, Apple hasn't provided an easy way to disable this functionality. However you can deny global access to the application that provides AirPlay mirroring by changing its unix permissions

In order to disable AirPlay mirroring, we have to deny the computer access to the application that allows the computer to AirPlay mirror: Fire up a terminal and enter the following command:

sudo chmod 000 /System/Library/CoreServices/

Enter the administrative password and restart the Mac afterwards. If you try to AirPlay mirror to an AppleTV now, the AirPlay icon will stay blue, as if it's still trying to connect but it never will.

The only disadvantage is that it locks up the menubar. The user won't be able to use any of the menu bar items after they tried mirroring the screen. You're still able to adjust the volume using the keyboard, though. Logging out and back in will restore the functionality of the menubar until you try to use AirPlay mirroring again.

To eliminate the temptation of using AirPlay you can hide the AirPlay icon by opening System Preferences > Displays and unchecking the "Show mirroring options in the menu bar when available" checkbox. You will need to repeat this step for every user on the system.

share|improve this answer

It has been a while since I set up Airplay, with Airport express, Airport extreme, and Apple TV, my airplay is password protected. Below is a link to an apple article about setting up airplay using Airport utility.

share|improve this answer
Just pointing someone generally to a support article is not really helping.A quote of the part relevant to the question would improve your answer. – Saaru Lindestøkke Jan 19 '14 at 13:23

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.