Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

OS X is showing me some folder and filenames, per default in reverse alphabetical order. Why?

share|improve this question
up vote 5 down vote accepted

If you take a close look at your Finder bar, you'll see a little triangle that is to the right of "Name" (which is just above the file names).
Click it, Finder will order your files alphabetically and Finder will remember your choice. By so, it will display the list in alphabetic order next time you open a Finder window.

enter image description here

share|improve this answer

If @Michiel's answer doesn't work for you because you don't have a clickable list header, like in this picture:

enter image description here

Then what you need to do is set Arrange to None. You can do this through the View menu dropdown or the Arrange dropdown that is just below and to the left of the Documents Icon in the picture above.

share|improve this answer

HOWTO: Fix file sorting in Finder’s column view on Mac OS X Lion

I’ve been banging my head against this one for a week now: Finder just wouldn’t sort things alphabetically for me. I use column view, and it seemed that my old ^⌘1 and ^⌘2 keyboard shortcuts weren’t working.

Mac OS X Lion’s Finder introduces two ways to sort: Arrange By and Sort By.

Arrange By is more useful in icon view and list view. Setting Arrange by to something else, such as Kind or Last Opened, will have Finder ‘arrange’ the file listing into categories which are ‘sorted’.

If you go to the View menu you’ll see Arrange By. If you then hold down Option (⌥) you’ll get Sort By. Here’s where I got caught out. If you have the submenu open when you start holding Option, you’ll need to have the menu close and reopen before you get the right options.

When working correctly, in column view it seems that the Sort By menu will be disabled unless you have Arrange By set to None.

There’s also a “Arrange” button in the toolbar now, which will display the Sort By menu when you option-click it.

So, if your sorting isn’t working the way you want it, here’s how to reset it:

View > Arrange By > None (^⌘0)
Hold Option, View > Sort By > Name (^⌥⌘1)
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.