Ask Different is a question and answer site for power users of Apple hardware and software. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Using RedSn0w, I tried to jailbreak iOS 5.1.1 on a 3GS and at the first step of "preparing" an error comes at 91% completion saying: "Error 2000". What does this mean and how can I fix this?

share|improve this question

I had the same problem. turn off your iphone and put it in DFU mode than start redsnow, jailbrake and let it install. it worked for me.

share|improve this answer
Thank you, how do i put it in DFU mode? – iOS noobie Jun 9 '12 at 3:12
There's a nice walkthrough here -… - you need to hold down certain buttons at different times. – user479 Jun 10 '12 at 3:00

DFU mode is the secret! Try this video out; it helped me a lot:

share|improve this answer
Welcome to Ask Different! Answers on Ask Different need to be more than just a link. It's okay to include a link, but please summarize or excerpt it in the answer. The idea is to make the answer stand alone. Please take a look at the FAQs for more info. – gentmatt Sep 27 '12 at 6:22

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.