Ask Different is a question and answer site for power users of Apple hardware and software. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Because I lost my iPhone 3GS headphones (those with microphone and remote control), I now tried to use the latest ones (from iPhone 4S). The microphone is working, but somehow the iPhone doesn't react of the remote control (Accepting calls, stopping the music, or changing the volume doesn't work at all). Are the new headphones generally incompatible with the iPhone 3GS, or is it a different problem?

share|improve this question
up vote 3 down vote accepted

I had this issue with my iPhone 4. Turns out some debris got in the headphone jack. As the 3GS is an older device, the contacts may be dirty.

Try taking a cotton swab with most of the cotton removed and dipping it in rubbing alcohol. While it's off, clean the sides of the headphone port on the 3GS.

Let it sit for five minutes and turn it on. See if that helps.

Another thing you can do is quickly and forcefully insert and remove the headphones in question to (hopefully) clear anything blocking the contacts.

Personally, I'd try the first option first.

share|improve this answer
I tried cleaning the input with a cotton swab (with a very very little bit water) and it worked! Thanks very much! – Dion Jun 8 '12 at 17:08
Glad it worked out. One of the water sensors is in the headphone jack so hopefully it wasn't enough to have that sensor change color. – bassplayer7 Jun 8 '12 at 17:09
That's why I suggested rubbing alcohol. – Kalamane Jun 8 '12 at 17:13
Yes, unfortunately I don't have any here now. But I only made the cotton a very little bit wet, so no water could get into the iPhone.. – Dion Jun 8 '12 at 17:30
Well, I'm glad it worked. :) – Kalamane Jun 8 '12 at 17:34

They are compatible, and they (at least partially) work because you can use the mic.I suspect that the buttons themselves may be broken. Try using the buttons in a recent Mac unibody laptop or in another iDevice.

share|improve this answer
Thanks for your quick answer. I connected the headphones to my Macbook Air, and controlling iTunes worked perfectly. So if they are really compatible, it must be something broken in my headphones in-/output of the iPhone :( – Dion Jun 8 '12 at 16:47
Try rebooting the phone. Sometimes the play/pause button on mine stops working, but only in the Music app, so rebooting fixes it. – CajunLuke Jun 8 '12 at 16:48
Rebooting the iPhone I already tried a couple of times, I'll try to clear it if something is blocking the contacts.. – Dion Jun 8 '12 at 16:53

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.