Sign up ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I'm trying to connect remotely to a family member's new MacBook Air from my own iMac. Both machines are running OS X Lion.

I can connect to the files on the remote machine and I can see the screen of the remote machine.

But I cannot interact (mouse or keyboard) with the remote machine.

I can run LogMeIn (free version) with no issues. But I'd like to log in to the machine remotely with no input from the family member - it shaves at least 30 minutes off the support call. ;-)

Any idea what I'm doing wrong?

share|improve this question

3 Answers 3

Most likely you have Observe Mode enabled on your end. In Screen, go to the View menu. You should see an entry for "Switch to Control Mode".

share|improve this answer
Thanks for that. Sorry, should've said - Can't switch to control mode either. So I guess the question is: why can't I access control mode? – Paul A. Jun 8 '12 at 17:49
Can you confirm that the remote machine is set to allow control connections? Alternatively, if you have SSH access into the remote, you can use the "kickstart" command, something like: sudo /System/Library/CoreServices/RemoteManagement/‌​ckstart -configure -users adminuser -access -on -privs -all -clientopts -setmenuextra -menuextra yes -restart -agent -menu -console – da4 Jun 9 '12 at 22:59
Yes, I think so: in the Systems Preferences, Sharing panel, "Remote Management" is on, and I allow access for "All Users" Is that enough? I'll try the kickstart command tonite. – Paul A. Jun 10 '12 at 13:32

I had the same issue and carried out the following steps.

  1. On the computer that you are sharing(viewing) access "Sharing Preferences" (System Preferences -> Sharing)Tick the Checkbox titled "Remote Management"
  2. Click on the Text "Remote Management"
  3. I recommend that you Only allow access for specific users. ( I use the same account on both machines). If you do this make sure you add the user to the list
  4. On the right hand side within the "Allow access for" section - Click on the Options button
  5. Grant the user/s access to the functions you wish to carry out.

Lastly, restart the screen star from on the Computer that you are viewing the Shared Screen from.

This should do the trick.

enter image description here

share|improve this answer

I have a Mac Pro and a Mac mini both with Lion installed. What I did for screen sharing is that I set up a administer account with a password on both machines. When using screen sharing, I log in using the administrator password instead of using the code in the sharing setting.

Note that in the sharing setting, only the administers are allowed to modify/control the screen without a VNC pass code.

share|improve this answer
My screen sharing works well in my local network. problem is I'm connecting via internet (and two continents ...) to the remote machine – Paul A. Jun 10 '12 at 13:33

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.