Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

This had never been a problem until around an hour ago. A friend texted me and it showed up on all 3 other iPhones my family has (we all use the same Apple ID). I tried turning my phone off and on, then turning off iMessage, then sending it through my own email (which didn't work, because her texts just sent to everyone but me). This has never happened before, please help!

share|improve this question
add comment

1 Answer

On your own iPhone, go to Settings > Messages > Receive At. Tap Caller ID and make sure it is set to your phone number.

Optionally, on the other iPhones, go to Settings > Messages > Receive At. Tap your Apple ID at the top of the screen and choose Sign Out.

share|improve this answer
    
The Apple ID is separate to the iTunes Store ID, even if they're the same address. You can still leave your family signed in your ID for purchases, etc., but each have your own personal IDs for cloud services and iMessages. –  Hand-E-Food Nov 27 '12 at 3:55
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.