Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I've been watching lots of .MKVs lately, opened from the Finder. In Column View, when you single-click any file, QuickLook will load a viewable thumbnail into the next column over. This causes noticeable and repeated momentary hangs in Finder responsiveness.

I have a feeling this is related to a non-Apple-kosher file-type like Matroska Video giving QuickLook some problems.

Has anyone had experience with this problem, OR have a way to disable QuickLook entirely? I ask because I would rather have my OS always be responsive than have CPU time eaten so that a useless thumbnail can be loaded that I never use.

share|improve this question
    
Just guessing here, but could you theoretically prevent the helper from running via a shell script? –  Redandwhite Jun 6 '12 at 11:07

3 Answers 3

Open Terminal, type:

sudo nano /System/Library/Sandbox/Profiles/com.apple.qtkitserver.sb

This will open the nano editor with the rules file. Scroll right to the bottom of this file and enter:

(deny file-read* (regex #"^.*\.mkv$"))

After this do Ctrl-O and then Ctrl-X to save and exit the application.

Reference: http://forums.macrumors.com/showthread.php?t=1463364

share|improve this answer
1  
For mountain lion you should also edit com.apple.qtkittrustedmoviesservice.sb –  skiabox Jul 6 '13 at 20:43

A quick fix would be removing Movie.qlgenerator from /System/Library/QuickLook/ folder. This will disable thumbnail creation for all movie files, not just MKVs.

A better fix (if you know what you're doing) would be to restrict the Movie.qlgenerator plugin to only displaying content of certain video formats:

Right-click on Movie.qlgenerator - you should be able to open its Contents folder and see its Info.plist file. You could try modifying this to exclude .mkv files; unfortunately there's no way to do this directly, but you could modify the LSItemContentTypes part to only include types that aren't .mkv.

You absolutely must backup Movie.qlgenerator before doing this. Anyway, once you've backed it up, open Info.plist in the original plugin within the Quicklook framework; you'll probably need to use XCode, or you could try using plutil on the command-line if you're comfortable with that (plutil -convert xml1 <path_to_Info.plist>), since the .plist is in binary format by default.

Find LSItemContentTypes (in XCode look for Document types then Document Content Type UTIs). This is an array of items, with one entry of public.movie, which basically means "any movie that Quicktime can open".

Remove this and instead add entries for the following UTIs:

com.apple.quicktime-movie
public.avi
public.mpeg
public.mpeg-4
public.3gpp
public.3ggp2

(or the UTIs for the movie types you would like to keep the previews for)

share|improve this answer

"A quick fix would be removing Movie.qlgenerator from /System/Library/QuickLook/ folder. This will disable thumbnail creation for all movie files, not just MKVs."

Re 10.8: Does nothing, the next time you boot it will be right back.

Why not just use the "Show View Options" in the Finder and uncheck "show icon preview" and/or "show preview column"? Can do it at the folder level or individual file level. Sort of what its there for.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.