Ask Different is a question and answer site for power users of Apple hardware and software. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

To add an custom mail-signature in Lion you had to add an signature via preferences, and then replace the contents of the webarchive with your own.

In Mountain Lion, Apple replaced the webarchive format for signatures with an new format: .mailsignature. When I open such an file, I just see HTML (!). But when I change it, it doesn't take effect..

Does someone have an solution to perform this?

share|improve this question
up vote 4 down vote accepted

Quit Mail, edit the .mailsignature file with a text editor changing the HTML to whatever you like then right click the file in Finder and select "Get Info" then tick the "Locked" checkbox. This prevents Mail from resetting the file to the original version and it uses your version.

share|improve this answer

• open Mail
• create a new signature
• open this folder /Users/you/Library/Mail/V2/MailData/Signatures/ • open the latest *.mailsignature file with a text editor
• replace everything under this code with your custom html (replace iso-8859-1 with utf-8 for umlaut support)

Content-Transfer-Encoding: quoted-printable
Content-Type: text/html;
Message-Id: <DDFB0C4D-5555-475C-9B54-115039EF5FE0@Speedport_W_722V_Typ_B>
Mime-Version: 1.0 (Mac OS X Mail 6.0 \(1486\))

• save the file and open the Get Info Dialogue and check Locked, so that it doesn't get overwritten by Mail

share|improve this answer

protected by Community Nov 23 '12 at 20:16

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.