Sign up ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Since one of OSX Lion's software update I'm facing a strange behavior with some of the apps installed on my mac.

For example with Onyx - when launching it by double click on I'm getting the following error:

AppleScript Error:
sh: sw_vers: command not found (127).

If I run Open, it works OK.

I've been trying to re-install OSX from Mac OSX utilities, and it was OK but after the first OSX software upgrade that error occurs.

I'm not sure is the default path setting issues since cat /etc/paths yields the following:


What is wrong with my system?

share|improve this question

1 Answer 1

up vote 0 down vote accepted

Add /usr/bin /bin /usr/sbin /sbin /usr/local/bin to the PATH variable in

/private/etc/launchd.conf solved the issue.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.