Ask Different is a question and answer site for power users of Apple hardware and software. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My iMac (mid 2010) keeps pestering me to upgrade my EFI firmware to 1.8. Sadly, no matter how many times I try to to upgrade the EFI (from the manual install, or the auto update), it does not seem to go through and asks me again at the next reboot.

The main reasons seems to be that I am running Mac OS X on a completely external disk (firewire); I am reserving the internal disk for Windows. I believe it’s the reason for my trouble since you can find many people have similar problems when they are running os x from a second internal disk (usually when they replaced a MacBook or iMac SuperDrive by an SSD drive).

Searching on the internet, I found a couple of resources that seem to indicate that manually blessing the firmware is possible. For instance this one; note their solution is for a slightly different problem, where installing Ubuntu messed up with EFI, but everything is running from the main disk.

I downloaded the firmware, extracted the relevant file (IM112_0057_01B_LOCKED.scap), and tried—unsuccessfully—to manually push the update.

I am not quite sure how bless works, nor where the efi update is supposed to live (i am surprised that it seems to live on the disk, not on the computer itself, but I could be misunderstanding the way EFI works). I tried:

sudo bless -mount / -firmware blabla.scap
sudo bless -mount /Volumes/Main -firmware blabla.scap

No success! If anyone who better understands EFI / the bless command can help me out, I would be super grateful.

I can share the output of the --verbose command if it is helpful.

share|improve this question
I figured I would add the verbose output, though it's a bit of a mess: – Theo Jun 1 '12 at 15:18
Note to self (this may go towards an answer): – Graham Perrin Mar 31 '15 at 3:32

I have had a similar issue when using a newer version of OS X than the system originally came with. Booting into an external system of the original operating system (in your case, 10.6 Snow Leopard) allowed the firmware to install and stop asking.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.