Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I'm running Mac OS X Lion 10.7.4 on a late 2011 MBP. I use a Logitech mouse with it, and rely on the Logitech Control Center software to configure the mouse speed/acceleration (I prefer it over the Mac OS X mouse acceleration).

The problem is that every time I boot up and log in, the mouse pointer will be extremely slow for about a minute, because it takes a minute before Mac OS X loads the Logitech Control Center. Is there any way to get Mac OS X to load it earlier?

EDIT in response to gentmatt's answer:

You are right, when I uncheck the "Reopen all windows when logging back in" box, then the Logitech Control Center loads almost immediately when I log in.

However, when I check that box, it doesn't take the Mac a whole minute to reload all my windows. For example, I just tried it with 6 Firefox windows open and Activity Monitor open. When I logged back in, all 6 Firefox windows and the Activity Monitor finished loading in no more than 10 seconds, however the Logitech Control Center still took about 1 full minute before it loaded. I was watching the processes in the Activity Monitor, and during that minute there was no activity at all while I waited for the Logitech Control Center to load, and then all of a sudden 7 different processes loaded at the same time (backgroundinstruments, warmd_agent, imagent, AirPort Base Station Agent, Logitech Control Center Daemon, EpsonLowInkReminderAgent, and iTunes Helper). Why would those processes take a minute before they loaded, when the Firefox windows and Activity Monitor finished loading after just 10 seconds?

EDIT (June 3):

@gentmatt: Do you run Firefox? I just noticed that Firefox seems to be causing this problem. When I restart with the "Reopen windows when logging back in" box and still have Firefox running, then I'll get the 60 second delay for the Logitech Control Center and other processes when I log in. But if I quit Firefox before I restart, then there's no 60 second delay when I log in again and the Logitech Control Center and other processes load immediately when I log in. I just tried restarting without Firefox open, but with some Chrome and Safari windows still open, and when I logged in again, the Logitech Control Center loaded almost immediately before the Chrome and Safari windows had finished reloading. So the 60 second delay definitely seems related to Firefox.

share|improve this question
    
How many log in items do you have and can you thin out that list or postpone some with a script like one answer proposes? –  bmike Jun 4 '12 at 0:05
add comment

3 Answers 3

Something you may consider is loading all your login items with an AppleScript as such:

tell app "Logitech...." to activate  
delay 10 --you don't have to have this, but it spaces out your items
tell app "Another app" to activate
delay 10
tell app "3rd app" to activate

Etc. To save this as an application, in the save dialog, select "Application" for "File Format:"

To open the application on login, just add it like you would add any other application.

share|improve this answer
add comment

I assume that you check the "reopen all windows upon next login" window when you shut down. I have had the same problem.

The workaround is to disable reopen on login. Then the login items will be loaded much faster. I'm not sure if this is a bug and if Apple is working on it. But I'm sure that this is in fact your problem if you rely on a 3rd-party-app to use your mouse properly.

However, you should also check the settings in System Preferences → Mouse → Tracking Speed.

share|improve this answer
1  
While one workaround might be to disable reopen on login as you suggest, I prefer the other workaround of never logging out or shutting down. The sleep function on Macs has been great for years and I rarely see a reason not to use it. –  Mike Meyers May 30 '12 at 9:50
    
@MikeMeyers Of course, that's even better! The sleep function in OSX is great. –  gentmatt May 30 '12 at 10:04
    
@gentmatt: Please see my new findings - I need to edit my original question to fit it in there. –  pacoverflow May 31 '12 at 5:36
    
@pacoverflow In response to the edit: I experience exactly the same as you. This is even though I have a SSD! The reason is unclear to me which is why I posted this question. According to the (only) answer: "It appears... that the login items get started after all the applications from the last session have started up." Maybe some of the applicaions still load in the background after you already see them. You have to wait until they are finished loading to see your menu extras being loaded. - This is only a guess though. –  gentmatt May 31 '12 at 6:05
    
@gentmatt: See my latest edit. –  pacoverflow Jun 3 '12 at 23:55
show 1 more comment

The only way I can think of is to add the Logitech Control Center app in the list of app which launched at startup.

Preferences < Accounts < Login Items
enter image description here

But considering the fact it takes your Mac about a minute to load this app, I'm guessing the app is already in the list.

The fact that you have to wait a minute or so means your Mac is still booting (and loading all the software). I can't think of a way to increase this speed beside adding a faster drive or adding more RAM. But that's quite radical (and expensive) just to make your boot process a tiny bit faster.

An other thing you can do to speed up the boot process is to limit the apps your Mac has to open automatically (so it will get to the Logitech Control Center faster) and to clear your desktop (so you Mac don't have to waste time and RAM by loading all these icons and shortcuts).
This and more tips, are listed in this (rather old) article.

share|improve this answer
    
Michiel, the Logitech Control Center cannot be found anywhere in the Applications folder (or the Utilities subfolder). It does appear in the System Preferences in the Other section. Also I am about to post another comment - this isn't a problem with the Mac OS X trying to load too many apps before it can get to the Logitech Control Center. –  pacoverflow May 31 '12 at 5:29
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.